Stuck on homing for almost 30 min

When I turn on my laser I’m stuck on homing and the camera is not showing what’s inside the laser. It’s been stuck here for almost 30 minutes. Sooooo frustrating!

1 Like

Yep it looks like they are having another server issue AGAIN. This is the 3rd day in a row they have been having issues. It was good for me last night, Slow again this morning, Pretty good this evening and now its taking 10 minutes to focus and 10+ minutes to process my project. Its crazy!

Yeah that’s where I’m at too now. It’s stuck on preparing my print and has been there for 20 minutes.

I have limited connectivity? What’s going on?!

2020-09-27 @ 6:24am (Pacific Time) - I’ve been having this issue since yesterday. It’s beginning to concern me a little.

I guess I’m only a little bit happy to hear others are experiencing this issue as well… as it means the problem is (hopefully) not my Glowforge.

I’m stuck on processing when I load a design… then it errors out half the time. This stinks

Same here. Been trying for the last hour with the same result.

You need to open your own support thread, they can only assist one customer per ticket.

Rest assured, I did that yesterday. :slight_smile:

My hope is they get this fixed by Monday as I don’t think anyone ever responds Sat/Sun.


Mine was stuck on “cooling down” for over 30 mins. yesterday…I finally just gave up. Then the other day it was stuck on “centerinig”. I’m new to GF and this is really worrisome. This is the second time the software/program doesn’t allow me to use my machine. Is this a frequent issue? I might be sending mine back. I’m not feeling confident my investment is going to be reliable to sustain a business with all these issues.

WIFI,WIFI this will be an ongoing issue without a hard wire port.

I’ve been having centering issues since 9/26/2020. Machine worked fine 9/25/2020. Today, 9/27/2020, still the same centering issues. Displays the last job I did, 9/25/2020, on screen and the image doesn’t refresh to show what currently is in the bed. Hopefully issues get resolved Monday.

1 Like

This issue has nothing to do with wifi. It’s a server issue, even if your hardwired you will have an issue.

1 Like

Yes, I’m having the same issue. I see the last job (from yesterday morning). The bed image does not refresh, and I’ll either get stuck on “Centering” or “Scanning”… even if I leave it and walk away for hours.

I’ve been using my machine for years without issue. This is a first for me. I guess the unnerving thing is that the arm/head never move… ever. I would not have guessed this part was cloud-based.

My Glowforge keep saying no Artwork and the laser is not reading

I’m so sorry to hear about the trouble you’ve been experiencing. I’ve extracted the log files from your Glowforge, and it appears you’ve been able to print since contacting us. Could you let me know if you’ve experienced the same trouble? The errors you experienced may have been related to an outage we’ve had previously, which has been resolved.

Have you tried a different browser? I uploaded my design on my computer and then went back to it on my cell phone. it loaded in *almost normal time

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email