Stuck on Preparing your Print

Last night I was unable to get my Glowforge to print. It would do the auto-focus and then move onto Preparing your Print, but it would stay there and eventually give me an error saying to refresh my browser and restart the glowforge. I did both several times to no avail. This happened on several different designs, including ones that printed successfully over the weekend. They are all pretty simple engraving jobs. Any suggestions on what to try? I have emailed support and got an automated response with ticket #156681 but I have yet to hear anything else. Not sure what else to try.

Hi–welcome! Hope this gets resolved quickly. Have you tried clearing the cache on you computer? That often helps clear out gunk “clogging the pipes” that affects how well your system runs…

Yes. I one of the times I did the whole refresh browser and power cycle the glowforge I fully closed the browser, restarted my computer, opened the browser, cleared the cache, and then went back to app.glowforge.com.

Just in case it’s a confused router, it wouldn’t hurt to try power cycling the router. Or you can do a setup using your smartphone as an access point and see if things work. That would help you troubleshoot whether it’s a WiFi issue or not (which can be the case even if other devices are successfully connecting to WiFi).

Ok. I have tried that. It didn’t help. I have managed to get some things to print…but it seems like sometime in the past few days most of my designs suddenly won’t work any more, especially engraves. I was able to print several jobs with just cuts and several where I took my design and broke it into piece to print one at a time, but then what was normally a 30 min print turned into 15x 2 min prints, doing one piece at a time. Did anything change with the way the process engraving jobs recently?

As an update. I had a few e-mails back and forth with support folks and they were able to find and fix what ever the issue was. My designs are working again.

2 Likes