Stuck on "Rendering your design"


For the last week we have been having the problem of being stuck on “Rendering your design…”

We have looked through the forums and have tried various ‘fixes’ all to no avail.
We have tried:

  • Resfreshing the web page.
  • Resfreshing the browser.
  • Restarting the browser.
  • Restarting the glowforge.
  • Reinstalling the glowfore (re-connecting it to the internet/comp with the teal light)
  • All sorts of combinations of those.
  • Even making sure our zoom % is at 100%…

I did find a workaround… Instead of trying to load a design, I click the ‘trace’ function. That actually loads a view of the glowforge. I then drag and drop my file onto the bed area. It takes a long time for it to process the design … tick … tock … It’s a simple file, but it still takes a L…O…N…G time. But at least it’s up and I can use my glowforge.

Is there any way the “Rendering your design” glitch can be fixed?

There is no problem with my internet as we have been using it for months without this problem. Also we have been using firefox without this problem.

Thanks for any help!

1 Like

There are a couple of things you can try:

  1. First the Firefox browser has had issues in the past. The most trouble-free browser to use with this is Chrome since it interacts well with the Google Cloud. Changing browsers might take care of your issues.

  2. The other thing to try, if you haven’t already, is to just drag and drop the file onto the Dashboard:

You do not have to open the Trace function first.

If the file is taking a long time to Render, there might be something in the File itself that is causing problems. If you want to Zip and upload a particular file that is having trouble, someone might be able to find something in it that can be changed and make it render faster.


Chrome fixed it.

And to think I have been using Firefox all this time… Oh well. Just glad we are up and running again!

Thanks Jules!


Glad it worked! :grinning:

Good to hear you’ve found a solution!

I’ve NEVER used anything except Firefox with the Glowforge. No issues. I’m on Firefox 61.0.2 (64-bit) under Windows 7. But, that being said, trying Chrome is my go-to “fix” when Web pages don’t work as expected. I use the Firefox “Open in Chrome” plug-in to get there in one click! :sunglasses:

A computer is like an Old Testament god, with a lot of rules and no mercy. — Joseph Campbell


I’m glad you resolved it! I’m going to close this thread - if the problem reoccurs, go ahead and post a new topic. Thanks for letting us know about this!