Stuck on Uploading- ideas

I got my GlowForge last week and have it all set up. Went to do the first print in the manual, the Good Measure key chain…it wont upload and print. Today we added a Google point the the work room next to the Forge, laptop beside it. Is been on upload for over 15 minutes ??? Anybody had this problem or have any ideas about a solution while Im waiting to hear back from Support ?

Smells like wifi maybe.

How’s the signal strength where the glowforge is?

Have you rebooted your wifi router? Always a good first step.


I’m not sure ? It’s ma 1700 square foot house , the internet is fast throughout. Ill give rebooting a try.

1 Like

Weak WiFi or router shenanigans account for a lot of the really strange stuff you see.

Sometimes your router needs a solid rebooting to clear out the digital cobwebs. (Or more precisely ensure that the DHCP system is properly assigning new IP addresses.)

1 Like

Evan …guess what ? I tried on my iPhone last night and it worked ! This morning , my laptop worked like a champ ? Weird . iPad gets a 500 something error . Making progress . Wanted to thank you for trying to help me yesterday !



If it was network related, it could have been lots of things. You might have had some interference on the channel that your router was using, etc. If you’re in a crowded area other people’s wifi network can impact yours. This isn’t a glowforge thing exactly, more of a wifi issue.

A good rule of thumb: if the GF starts being really weird about setting jobs up, try rebooting your router and GF and see if that helps.

1 Like

This topic was automatically closed 32 days after the last reply. New replies are no longer allowed.