Suddenly getting a bad path... Anyone have this issue?

Cutting from a template I’ve used a hundred times, no changes have been made to the svg file and today it suddenly drew a straight line instead of the contour.

Checked the source file and there is nothing different. Created a new version and got the same result. Only with this shape and again, I’ve cut this hundreds of times.

Any thoughts? Help?

Couple of things to try:

Try printing one copy of that right-most file placed closer to the center of the bed. If it works fine and isn’t flattened, it’s not a file issue, there is some kind of mechanical issue causing it to get caught.

If the file doesn’t print better when it is placed farther over to the left, it’s a file corruption.

From the motion it’s following, it looks like there might be something on the laser arm, or maybe the ribbon is twisted. Check that over carefully.

It’s the damnedest thing. I tried moving it left, down, turned it sideways and it still prints that side flat. Opened the file and recreated it from scratch, but every time I cut that shape that side flattens. The had never happened before today. The pattern is an earring my wife has been selling for a year and it’s never failed.

Okay, that’s good, at least it’s a file issue and not a mechanical one. I can take a quick look at it if you like to see if i can spot anything, but I’m surprised that recreating the file didn’t fix it.

1 Like

Bad vertex. Converted it for 3D printing and was informed that that the top vertex was effectively twisted inside out.

I’m baffled how I’ve printed so many before this. GF update rendering software in the cloud perhaps?:thinking:

1 Like

Huh! No idea why it suddenly wouldn’t interpret the same way it did before, but I’m glad you found it. Maybe they made a behind the scenes change to the rendering software on their end.


You can be sure GF is tweaking their path generator all the time. It’s in the cloud for exactly this reason. My guess, an earlier version saw the bad vertex and did something besides ignore it that happened to work out well anyway. GF fixed that part of their parser so now the bad vertex is being rejected. Something it should probably have been doing all along.

I do CNC machining and 3D printing as well as lasering. I have used geometry to successfully print objects, only to find when I modify them slightly they don’t print correctly anymore. Because I had a geometry error the slicer didn’t care about until I changed it ever-so-slightly and then it did.