SVG File Rearrangement

For what ever reason my logo does not carry over to GF in its original form. It is a SVG and I am using Inkscape. Everything looks great in Inkscape. I have tried to group, ungroup and object to path with no luck. Anyone have an issue similar to this?

Need a lot more info. Are you using clips? Patterns? Gradients?.. none of those transfer to the GFUI. There are many other details about vectors that you need to understand to have a good transfer.

Posting pictures would help.

Did you copy & paste in any PNG or JPEG element? That’s caused failures for files to load for me. Instead, you need to IMPORT that type of image file into your SVG file & save as such, and then it does upload OK to the GF.

I imported it :frowning:

I generally drag and drop but have just opened png or jpg in inkscape and worked from there.

1 Like

logo

Please excuse my mess LOL

1 Like

I forgot to mention that my logo was made by WIX (website) Logo Maker.

Couple of issues with it:

  1. First …always use a 12" x 20" artboard to design on…this one had the logo way off the artboard and that can interfere with it opening.
  2. No patterns. The GFUI doesn’t interpret them. I rasterized the pattern along with the text and it should now pick up correctly as an engrave.

logo.zip (23.5 KB)

2 Likes

Huh. I opened it in Affinity Designer to see what was happening, and it looks just like in your GFUI screenshot:

00%20PM

1 Like

Mostly it is OK
It is buried deep in excess groups and subgroups, a couple of the groups are themselves scaled and moved about. All is enclosed vectors so engrave will be the thing I made the fill green and the edge black so you can see what is happening. The hand is one object instead of a group so should work better.

If they move about in the GFUI you can still move each separately to get how you want it.

Handmade%20by%20meissa

4 Likes

Thanks! I cleaned it up and it is perfect!

4 Likes

You guys are awesome! Thank you so much :smiling_face_with_three_hearts:

3 Likes

Weird right!

2 Likes

If you create a group and move and scale it after, and then try and ungroup it, the move and scaling reverts as it did here

1 Like

I’ve never had that problem before, i’m not sure if i group things differently but when i make a group scale and move it and then ungroup things they just stay exactly the way i want them. i use ctrl+G to group and ctrl+shift+G to ungroup. is that how you do things? edit-Maybe it has something to do with layers? i never mess with those.

2 Likes

I know people have posted fixed versions but i was still having your same problem when i uploaded it of the graphic being moved. I went in unlocked the layer and removed all groups, re-scaled it to the original sizes and made the hand one object for simplicity and so if you ever decide to score it you should not get any funky effects. The green fill one the hand is one object and the red fill one they are still separate so you can move them around if you wish after you ungroup them. Hope that helps.
68b4df503e0487138c0b28a54ee1b89841cff192
68b4df503e0487138c0b28a54ee1b89841cff1922

1 Like

I have seen it often enough, Good perhaps in situations where something needs to be scaled down for illustration, but mostly annoying in our situations making stuff to cut on the laser.

1 Like