SVG's upload but do not show up when opened

From the Dashboard I upload an svg. No errors. Thumbnail in Dashboad looks ok, when I open it the right hand settings section contains the correct thumbnails for the different colored parts.

However there isn’t anything in the main view so I can’t see or position any of the parts. Weird that everything else works. No idea what’s wrong or how to get it to work properly.

My guess is that you designed your image on an Artboard that is larger than the 20” x 12” bed size, and your images are off to the side somewhere. Possibly you can find them if you zoom way out. But I would be designing on a bed size Artboard if I were you.


My first step would by click CTRL+A to select all artwork and see if anything shows up. If it doesn’t, @cynd11 might be correct that it is off screen. Click the little ruler and select the top left corner dot. Then set the X and Y coordinates to 0 and see if it appears then. If not, then I got nuthin.


@cynd11 is right.
In your design software in preferences set up a work area (art board) at 12" x 20" and show outline.
With your design in that area it will always show on the bed.

Oh that’s a great idea. I had tried zooming out as far as I could to see if I could see the objects off screen, but did not see them anywhere even at full zoom out. However doing CTRL+A did cause the little ruler to appear as if something were selected, and that let me input a X/Y origin that let me rope that thing back to viewable space.

Saved! Thank you so much!


Yes, it’s funny some of my exports were showing up fine and others not, but I usually create a new doc for each save and maybe I just clicked on the wrong template for a couple of them since I was doing 6 exports. (My other main template is in mm for my 3D printer! )

I’m SO glad the CTRL+A solution works. That’s an easy fix for an otherwise mystifying issue.

Thank you so much! I’m back to the races. I’m so glad this isn’t some vector complexity cap issue or something. phew

Thanks for the answer @PrintToLaser , that’s right. I’m going to close this thread @kurt.schaefer - if the problem reoccurs, go ahead and post a new topic. Thanks for letting us know about this!

1 Like