Taking forever to render design and Create new outline

Does any one have this problem. As of recently it has been taking my glow forge for ever to render the design. Once it finally loads on the screen I can not create an outline for my design. It is so frustrating. Ive cleaned the heck out of my glowforge and no luck. It just loads forever when it says creating a new outline. Someone please lol

Yup, same. There was also a huge problem with not being able to select your artwork a few days ago that’s been fixed. But maybe not? I’m finding if I copy and paste to make multiple designs, it’s not copying the whole design (specifically the holes).

1 Like

Have either of you ran the gift of good measure? If that loads up ok then perhaps the problem is not the machine but the artwork.

Sometimes clearing your cache and/or using a different browser is helpful.

1 Like

Hi @brad650hill. I’m sorry to hear that it’s taking a long time for the Glowforge app to render your design and trouble creating a new outline. To help me review this for troubleshooting, could you let copy and paste the URL of the design that is taking a long time to render, or having trouble when you try to create a new outline? I can review that for any potential cause and decide on any next best steps to help. Thank you!

Everything seems very slow on the server side today. I’m having designs take forever today to render after I hit the print button in the app.

They are all designs that I’ve been using successfully for months, I have no idea what changed. Glowforge won’t even pull them up, it just says rendering … I’ve tried Chrome and Safari, restarting the computer, closing tabs, etc.

So one way to rule out wifi as the culprit is to try the gift of good measure. If that works it isn’t your wifi connection it’s your file. A simple test.



I’ll give that a try, thanks so much! Just wondering… if they are files that have worked for dozens of prints, why would it suddenly not work? Have you had this issue?

I have seen discussions here where those things have happened however I don’t know why. I have not personally had that issue but one way to rule it out is use something guaranteed to work.

Ok, I have been printing others and successfully printed the gift of good measure. About 1 in 6 of my designs are suddenly having this issue. I’ll contact support. Thanks for your input though!

1 Like

Hello! @brad650hill I’m Ray and thank you for working with my colleague Brandon. Could you do me a favor and attach the actual design file to your next reply? I’d like to take a look at the file myself to determine the next steps. Thanks!