Text conversion problems from Affinity Designer

I’m having a strange issue with Affinity Designer and text. I’ve used it before with no problems but all of a sudden it’s not converting correctly. I’ve tried several different times to convert the text to curves, I’ve tried not converting it but checking the box when I export, I’ve tried SVG and PDF files, I’ve tried using fill color with no line color and none of these seem to fix my problem. I can’t get my text to open up properly inside the glowforge interface. I’m attaching a photo of what it should look like (in Affinity) and what it ends up like in Glowforge (2nd photo). It seems like I’m missing something really simple but I can’t figure it out for the life of me!
Screen Shot 2021-06-24 at 3.00.25 PM
Screen Shot 2021-06-24 at 3.03.38 PM

1 Like

I use AD, also. I did a quick test. The reason there are dotted lines around the text is because it’s out of bounds.

This is what mine looked like when I dragged it out of the boundary area;

The other thought is that you have no material on the bed, yet?


Well, it was actually in bounds but not configured for printing yet. Once I configure it for printing it gets better but it’s still not accurate with that font. It is a new look for imported designs I guess? I’m thinking it might be the font. Sadly that font worked beautifully with Adobe Illustrator but apparently not with Affintity. I wasn’t able to ‘add’ the letters together once they were shapes either - just kinda clunky.

1 Like

After you convert it to curves, have you tried using a Boolean operation (Add)?

Since the text is a script font that overlaps other characters, it’s individual shapes for each letter, despite the merged appearance in AD. If you Add them all together, it will create one compound path.


Yes, that’s what I did all the time in Illustrator and even Affinity but for some reason it’s not working with this font?! Ugh. I got it to work with a different font though so I’m thinking maybe my font is the problem…

1 Like

Oh no, I’m sorry to hear you’ve hit a snag.

We’ve made some adjustments to the UI recently, you can read more here (https://glowforge.com/latest-improvements/cardboard-settings-new-catalog-design-pages-and-updates-to-the-ui).

The dotted lines are presented when a material hasn’t been specified in your Glowforge. Could you try selecting a material and let me know if the font updates?

Hi @alicia1. It’s been a while since we’ve seen any activity here, so I’ll go ahead and close this thread. Feel free to create a new thread if you run into any further trouble. We’ll be here and happy to help. Thanks!