Text Disappearing on Engrave

I can’t for the life of me figure out what’s going on here. I created a graphic in Affinity Designer and imported it into the Glowforge dashboard as an svg. It appears normal when set to score or cut, but certain letter disappear when setting the graphic to engrave. I tried exporting the graphic a couple of different ways, converting to curves, etc but no dice. I tried different engrave settings (draft, SD, HD, etc). Anyone have an idea as to what’s going on?

Graphic in question attached: nike_shoebox_side

This is one of those weird things I don’t fully understand, and I have no idea how to fix it in Affinity Designer. But when it happened to me, @marmak3261 opened my design in Inkscape and reversed the paths and my shapes magically appeared. So I did the same thing to yours, and voila:

Here’s the corrected file:


(P.S. It has something to do with something called “winding rules.”)


That’s awesome! Thank you!

I double-checked Affinity and the fill is using Alternate rather than Winding. If I flip it to Winding, sure enough the letter disappear in Affinity. So maybe it has to do with the way Glowforge is rendering the svg?


Correct. The SVG winding rules are not handled correctly by GF. It’s a known & longstanding issue. They did update it (they called it a “fix” :slightly_smiling_face:) to at least drop the artifacts in the UI operation view vs showing everything and only after your job finished would you see that it didn’t work.


We discovered this very early on and it’s still a huge pain in the arse. :roll_eyes: I don’t think I’ve seen the issue in anything other than Corel though.


I really wish Glowforge would fix this bug. The lack of support for the even-odd fill rule in their SVG implementation is one of the two biggest deficiencies in their SVG implementation. (The other one being the lack of support for clipping paths.)

It must be pretty embarrassing for Glowforge to let a bug like this remain for two years without being fixed.


I opened the svg in AI and noticed your compound path of the words and boxes has a fill and stroke. I turned off the stroke, saved and uploaded to test. I got the same effect when I uploaded the original file but uploading the new one which I only hid the stroke on and it shows everything for engrave correctly.

1 Like

AI likely converted the winding rule. It likes to do that.


Thanks for the help in this thread, everyone. I’m sorry for the trouble. I’ve let the team know about this, along with a suggestion for improved support of these SVG rules in our software.

If you run into any other trouble, please start a new thread or email us at support@glowforge.com.