The camera didn't take a picture error message

Has anyone found the solution to this?

I cleaned my machine yesterday as it was failing to cut through my proof-grade materials, so I assumed it was dirty. I cleaned according to the recommendations and since then, I have been receiving this message. I followed all of the ‘stuck calibrating’ steps recommended, but none are solving the problem. Ive found multiple discussions about this but no solution as the threads are always closed!

Please help, my machine is conveniently just past the warranty period and I have orders to get out :frowning:

If it’s not immediately obvious, the camera is connected to the machine via cables and connectors on the lid. If during your “cleaning” you touched anything other than the optics, then it’s likely you dislodged a cable, or possibly damaged a connector.

So I would start by carefully checking where the cables plug into the connectors.


This is what im thinking the problem is… im assuming maybe there is some moisture in there? Does anyone have any good tutorials or videos for opening those connectors to let them dry maybe? Found another forum on here and this is how they solved it (just dont want to cause any further problems haha), just not completely sure how to open them/ensure they are tightly closed

1 Like

Similar story here. It’s been hard to see my material on the dashboard because it’s so dim. I thought cleaning the led boards with a cloth sprayed with windex would be safe. I got the error my first attempt at printing after the cleaning. I opened and closed the camera cable connectors and it worked. A few days later it’s not working at all.

Having the same issues and have done everything suggested by groups and glowforge. Help!!


Did you ever figure out how to fix it or is it still happening to you too?

1 Like


It looks like we talked on chat yesterday and were able to get you a new black lid cable. To avoid duplicate communication and expedite your process, I’m going to go ahead and close this topic.