Totally baffled... need illustrator help

Can one of you ninjas please tell me what is wrong with this file? I get an unexpected error. Thanks! (1.8 KB)

Hm, I can download it and preview it, but can’t open it in Illustrator CS6 – it asks me to select a file format (BMP, PNG, etc) and then tells me that the plug-in can’t understand the file. Are you having a problem with the design not working, or could there be something wrong with the file itself?

I don’t know why the Glowforge doesn’t like it. I opened it in Affinity Designer and re-saved it (making no changes) and then the Glowforge was perfectly happy with it. <shrug>

Here’s the file I made with AD (edited slightly in a text editor to re-insert the original height/width in inches as AD always saves SVGs with pixel units). The Glowforge UI should load it fine.


it opened fine for me and apart from the top path (the base of the trees on the right) having a point that you probably didn’t notice it looks fine

Thanks all, but I am still baffled. I tried bringing in the file from a save image as, but it will only be a raster - thus it will only engrave. It is the only layer that doesn’t work.

I zipped up the illustrator file. i indicated which layer is giving me problems. It looks like the other layers to me. Thanks again!
04 (1.3 MB)

Did you try mine? The one I posted loads fine for me.

I tried. I don’t have AD and it loaded strange. I’ll try again.

That worked! Thanks! In still wondering what’s wrong with my file?

Nothing that I can see. I took your AI file and did a Save As… to SVG without touching anything.:

The resultant SVG:

Loads into the GFUI without errors.

So, two things to check: 1) that you used Save As instead of Export and 2) used the settings shown above?

Hope this helps!

Here’s the problem:


If you delete that from the SVG, it won’t produce the error message. This part of the part specifies an elliptical arc of radius 0.08, which I suspect gets rounded down to 0 and causes a division by 0 error somewhere in the Glowforge cloud.

What we’ve seen in the past is that certain versions of Illustrator generate these weird arcs, usually only with “Export” but not “Save As”. Last time it came up, I was unable to reproduce this with the current version. I’m at work now, but I’ll have to try it when I get home.


Bit of a correction, as I just took a moment to read up on SVG arcs and doing some experiments. It’s not actually the radius that triggers the crash, it’s the 0,0 coordinates at the end. And there’s no reason that should cause a problem. The arc should be from the current position (-5.55,8.42 in this case) to 0,0. I don’t have a good explanation why it can’t handle this, as it’s valid. But it can’t. Changing the end coordinates to 1,1 prevents the crash, as does replacing the arc with a line (l0,0). This is definitely a weird bug… I’m curious whether Glowforge is using any off-the-shelf code or if they wrote their SVG engine entirely from scratch.


Wow. Can you help me understand how you can see these coordinates? I’m new enough to illustrator that I don’t know how to debug this stuff.

And, thank you! This forum makes the GF great.

1 Like

He opened it up in a text editor to look at the SVG commands contained inside it.

Given the number of weird SVG bugs they have (e.g., they still don’t support “fill-rule: evenodd”) I’m pretty sure it must be written from scratch.