Trouble Loading / Printing Engraving Art with New Update

Since the new update, I am having a terrible time trying to upload my engrave files. Then when I do, they are not printing properly. They were just fine a week ago. It seems to want to break my art up into a million tiny pieces, even though I have joined all paths, etc. Most of the time when I try to upload I get an error or it times out. Not sure what to do. Cut is just fine, but the engrave files are not. Help is appreciated!

I don’t think the update changed anything at all about the engrave function of the Glowforge. Perhaps you can share a screenshot and a detailed explanation of one particular file that is exhibiting different behavior.


Thanks -the first image is what the file looks like, and the second is what happened when I tried to engrave. I have engraved this same file numerous times without issue. Suddenly it is taking forever to load, and it didn’t engrave correctly.

Well, just the engraved one uploaded - here’s what the file looks like. It was done in Illustrator. All paths are joined.

1 Like

Would you upload the actual file if you want someone else to test it or look at it. Missing the D and Y is not something caused by the new interface updates. You can also try converting the file to a pdf and see if that helps.

Thanks. Yes, here is the SVG. I did try as a PDF also. I am really perplexed on all of my engrave files that they are taking a very long time to upload, and sometimes even timing out. The GF is breaking the art up into a million pieces.

The file loaded for me in a matter of seconds. When I open the file in Inkscape, it is 17000 objects and the crab especially is a maze of 14000 nodes. I’ll bet someone skilled in AI will weigh in as I investigate further.


You may try clearing your cache to improve processing times. As for the interface breaking it up, in Inkscape the file is several pieces. The crab is especially problematic. I simplified the crab area and will see what happens. In general, I would have to say that the file is absolutely the problem. Not the update and not the Glowforge.


Marylander? Or as we say Murliner?

1 Like

Yeah that art has a lot of nodes, Any reason you’re not saving the image as a .png and engraving that way? You only need vector if you’re cutting/scoring…


Lol - yes! A Murliner, hon! :slight_smile:

I tried saving as a PNG also, but that wasn’t loading. It would load, but the machine would say ‘No Art’ so I could never get to the print stage. Just not sure why it would be fine a week ago, then not work. I will try clearing cache and doing other things today. Took a break from it this weekend! :slight_smile: Thanks for all of the help!!

A couple years ago I engraved a bunch of Maryland specific stuff. Both the wife and I were born and lived 50+ years in St Marys on the water. Even though we now live in the WV mountains the bay has a strong hold. Her Covid mask is an Old Bay print mask and she will put Old Bay on, or in everything. She buys it bulk style.

Made this MD puzzle from the perspective of a SoMD’r. It might make sense to you.
MD Map Final Text Converted_fixed
The two pieces representing the Bay are cut from a different color wood so it would stand out. Actually I cut two copies, one from maple and one from cherry. Then swapped the bay pieces between the puzzles.


Hello @kris4 I am so sorry the design is not loading into the app.

I reviewed the SVG you provided. @deirdrebeth is correct and, unfortunately, this image is too complex to be processed. This occurs very rarely, and it usually happens when a file is converted from another format. For example, it can occur if a raster file is converted to vector format with the precision set too high.

The best way to solve this depends on your design. You may be able to simplify the design with your design software. Inkscape and Adobe Illustrator both have options to simplify strokes. Another option might be to convert the portion of your design which is to be engraved to a bitmap by rasterizing it. Here are two support pages on these topics which might be helpful:

Rasterize Objects

Simplify Strokes

If you converted your image from another source, you might be able to perform the conversion again. In any case, your design will likely print successfully if it has fewer nodes (also called anchor points).

Please let me know how it goes.

Thank you Faryar - it’s working better today. Still taking a while to process. It’s just odd because I have used these designs before with no issues at all. The long load times and time outs just starting happening. In Illustrator I have joined the paths, which I thought would eliminate the separation, but it didn’t. I will give rasterizing a try to see if that speeds things up.

If they are one piece they will load faster. If you break the text up down to individual vectors and then use combine to make them all one thing all will go much faster, both in load and engraving time.

Hello @kris4 I’m so glad to hear it. I’m sorry the print is still taking awhile. Rasterizing the design should help speed up the process. I will go ahead and keep the forum post open for now. Please let me know how it goes.

Hi - Just letting you know that rasterizing the files worked well. It sped up the processing and the quality was still good on the engrave. Thanks for all of the assistance! :slight_smile:

Hello @kris4 That’s fantastic! I’m so happy to see that everything has been resolved.

I will go ahead and close the forum post but if you ever have any questions or concerns please don’t hesitate to reach out to us.