Trouble uploading design


#1

Hoping the many experts can help me.
I’m trying to upload a design and it won’t accept it. I’ve tried in SVG, AI, and EPS.
It won’t take them.
Any help would me greatly appreciated.


#2

Is it just this one file that is giving you issues or all files? It could be something in the file that the system doesn’t like. You could try deleting sections and uploading till you discover the area causing the issues.


#3

Not taking any of the EPS files I’ve tried.
Not taking other SVG’s either


#4

Give us a little better hint?

You won’t get AI or EPS to import, SVG is the GF native file format, but not all SVG is created equal.If you’ve embedded a raster file in your SVG the GF will want that too.

If you’re getting the red error message boxes on upload (clipping groups or something like that, or we don’t support fonts) that is going to require a little more work for you in AI. Check some of the tutorials.

You can upload GIF, JPG and PNG but those will only allow you to engrave.

If you like, upload the file that is giving you trouble. You can PM me with it if you don’t want iti shared to the world and I’ll take a look.


#5

Thanks.
These are files that I purchase, but also won’t take mine.
I was able to upload a .png.
Could you tell me the proper settings to “save as” in AI?
I looked on the tutorials and did a search, but came up short.
I’m sure that I’m doing something wrong.
Do you use the default SVG 1.1?


#6

Yeah, I’ve just been using the defaults for the “Save As” from the current AI CC version.


#7

You can’t use the Add Artwork button to upload an SVG, if that is what you are trying to do. That can currently only be used to upload raster files.(JPG, PNG, GIF.)

(No vector file types for that button.)

If you want to Zip up the SVG file and load it here, I can take a look at it, if that isn’t what you are trying to do with it. There are other reasons that an SVG won’t load through drag and drop.


#8

That’s what I’m using for the setting


#9

They did add a cool feature where you can have the home screen in the App open and just drag a file onto it to upload.

Keep pushing. I’ve made just about every mistake one can make with AI so far, and am busy trying to invent new mistakes to make, too :slight_smile:


#10

For Illustrator, make sure that Embed Artwork is checked, and that the Preserve Illustrator Editing Capabilities is NOT checked.


#11

Just trying to use upload to add an SVG file.
I’ve attached the file. It hasn’t taken anything from my yet except a png.Switch Plate Template sm_Switch.zip (54.1 KB)


#13

@teditz I just uploaded your file and it opened just fine without any adjustments etc.


#14

Well, then there is a problem on my end! And I’m SURE it’s USER error!!!


#15

Ok, now it’s saying that I cannot upload anymore files!!!


#16

If it makes you feel better, I can’t upload your file either. I went in and ungrouped everything, and split to separate layers. This uploaded fine.

Switch Plate Template sm_Switch copy ungrouped.zip (20.7 KB)


#17

I’ve had a few designs hang up and not upload. It was resolved with the old fashioned advise of turning off the GF and restarting. I seriously doubt it will change anything, but I re-saved the SVG file just for the hell of it. Who knows, maybe it’ll make a difference?

Edited to add: I removed the file for now. When I looked at the org file in wireframe, I could see several of the comma shaped pieces that were not joined correctly. You might want to take a look at those @teditz before cutting or I can do a quick fix for you if you like.


#18

That uploaded fine.
So it’s better to ungroup then?


#19

I wish I could be authoritative but like I said, I’m making mistakes right and left. It worked but that might be coincidence, I just don’t know.

I see @rebecca mentioned ungrouping above also.

I’ve got learning AI higher on my list now that I’m starting to play with the GF more.


#20

I didn’t ungrouped them, I had just opened and then resaved. Kinda weird that it worked when saved again. He, take a look at a few of the commas that need to be joined… might make a difference if you score those pieces.


#21

Did you open and save in AI?