UI not communicating with machine

Hi, I seem to be having some intermittent issues where the interface doesnt seem to be communicating with the machine. It gets stuck on centering or focusing - on the UI screen but the machine isnt doing anything. I have turned the laser off and the UI still says focusing. Ive refreshed the browser, restarted the browser, cleared cookies and cache, turned the laser back on and the UI hasnt changed - still stuck on focusing. I’ve moved the laser head to center under the camera - still nothing. This issue happens to me a couple times a week and I end up turning everything off and leave it for a day. I have orders to cut and its getting very frustrating. Any ideas how to get it running again would be appreciated.

1 Like

Your lid cable might be getting a little worn…there’s a list of checks to run through here to rule out other issues. If none of those fix it, the lid cable is the next obvious choice:


Thank you, I will go through the list. Good thing I just ordered a spare cable. I gotta say I wasnt impressed that the cable and the replacement lenses I ordered were just thrown in a box ( laser lens was just rolling around not in a bag or anything and the cable was folded and jammed in the box. For the $89 I paid in shipping I would have thought it would have been packaged a bit more carefully. Hopefully the new cable is functional.

1 Like

Have you tried accessing the GFUI from a different device altogether? Like a phone or tablet if there isn’t another computer avail?


No but I have never been able to do that. I dont have files on my phone so I never use it for GF

1 Like

I have noticed since the upgrade my machine goes ‘offline’ more often, I need to power cycle the GF to start it up again, my wifi is a good mesh system / and Wifi 6 - so more robust…

1 Like

Well give it a try, just to see if the UI is still stuck from another device. If it works you know it’s some thing with your computer. If it doesn’t then it’s something happening with your machine or wifi.

1 Like

Hi @m987456321. I’m sorry to hear that you’ve been running into issues with your Glowforge getting stuck during early stages of prints (centering/scanning/focusing). I see that the mention of checking the black cable was suggested earlier, and that you have previously ordered a spare black lid cable. Because of that, I wanted to check to see if you have already tried installing the replacement cable, and running into the same issues.

If so, it can help to get a better look a the lid cable connections. Could you please send us photos of the three connections, like these examples below?

Next, since this is intermittent trouble, it could indicate some issues maintaining a stable connection to your Wi-Fi network. When this is the case, you won’t need to go through Wi-Fi setup again, but you may see an “Offline” message.

The most common solution to Wi-Fi challenges is to restart all the devices involved in connecting to the internet.

  1. Turn off the computer, phone, or tablet that you’re using

  2. Turn off your Glowforge

  3. Unplug your modem

  4. Unplug your Wi-Fi access point

  5. Wait one minute, then plug everything back in and turn them back on

If that doesn’t work, we have two more suggestions that often make a big difference:

  1. Improve the signal path between your Glowforge and your Wi-Fi access point
    Wi-Fi signals need a clear path. Remove physical barriers, and move devices closer together:
    • Move your Wi-Fi access point up high and make sure it’s in an open space. Avoid locating your Wi-Fi access point on the ground, under a desk, in a cabinet, or in a corner where its signal can be blocked.
    • Relocate your Wi-Fi access point closer to your Glowforge
    • Move your Glowforge closer to your Wi-Fi access point
    • Install a Wi-Fi range extender closer to your Glowforge
    • Run an ethernet cable and install a second Wi-Fi access point next to your Glowforge

  2. Reduce electronic and Wi-Fi interference
    If your unit is near other devices that use Wi-Fi or a large number of electronics, temporarily turn off other electronics and devices in the area.

Also, I’m sorry to hear that you received your order with that packaging issue. I’d like to address that as well, but let’s start with checks mentioned above, and Wi-Fi troubleshooting. I can decide any next best steps based on any information received in your response. Thank you!


Hi, sorry for the delay. It seems to be working again for the time being. Here are the photos as requested.

On Jul 13, 2021, at 4:04 PM, Glowforge <support@glowforge.zendesk.com> wrote:

if it goes offline again, and won’t come back, try re-connecting it to your wifi (hold down button till it turns teal) run setup – see if that helps


1 Like

Hi there, no worries at all about the delay. I’m happy to hear that the issue appears to be resolved right now. I checked the connection photos, and they look fine. If you notice your Glowforge hanging during any stages of prints, or seeing any offline errors, feel free to reach out. I’ll leave this thread open to give you some time in case the trouble occurs, or you run into anything else. Thank you.