Unexpected Error occurring again


#1

Did a little work last night with the GF but was running into incredibly frustrating recycle requirements (1 print would work, I’d move the design in the GFUI and change the parameters and then it would hang on scanning or calibrating or just kick back to the GFUI…had to recycle everything multiple times and I’d get another successful print before having to go through it all over again…wasted several hours). So I finally gave up and shut down.

Tonight I went to work on a design, recycled things and sent an updated job to the GF by dragging and dropping the SVG on the GF app page. Got this:

Actually not that one, that’s a screen cap of the latest one. I’ve actually gotten that about a dozen times over the past hour. In between I’ve deleted elements from the design, dragged on a design that worked yesterday and still got that message. So I did the recycle dance a few times. No luck.

Loaded a job that’s in my catalog. That works. Loaded a GF provided one (ruler) and that works.

Created a square and tried that. Just a square. And I get that error.

Did you change the interpreter or something in the software? Here’s the SVG file.

test%20box

From about 7pm EDT to 8:45pm EDT.

I’m hanging it up again tonight. Will try again tomorrow but then I think I’ll need to fire up the Redsail because I can’t wait to have this resolved over several days or more as I’ve been wasting too much time on a time-sensitive project.

TIA


Errors Loading files originating from CorelDraw and Affinity Designer [Resolved]
#2

I couldn’t load it in the GFUI either, it might have something to do with the stroke.

When I opened it, it had a stroke width of 6.945 with no units showing but then selecting the rectangle and attempting to change the width of the stroke jumped that up to 45 pt.

Changing the width of the stroke to 1 pt fixed it though, and lets the rectangle load.

Square2.zip (759 Bytes)


#3

I’m getting this tonight too, on a file that ran fine last night.


#4

Interesting. Downloaded and opened yours in Inkscape and this is what it shows as the stroke:
image

Zero - not 1 or .1 or .01…

Here’s what mine shows:
image

And my version of Inkscape:
image

Did you use Inkscape or Illustrator to play with it?


#5

I looked at it in Illustrator. Had you thought of converting the units on the stroke to points instead of inches? Don’t know if it will make a difference or not, but you’re aware that stroke thickness makes no difference on the cut line anyway.


#6

So here’s an interesting one… y’alls discussion of the stroke showing 0 (@jamesdhatch) - I created just a no fill/no stroke square in Illustrator that gives me “unexpected error”, change the stroke to my normal .008" and it acts fine.

MT_NotMT.zip (1.6 KB)


#7

But if there’s no fill or stroke it would have to throw an error message wouldn’t it? It can’t see anything in that case. :thinking:


#8

Not necessarily. It still has path coordinates defined. No different than something being uploaded with both a stroke and a fill. And not really any different than being able to switch a closed vector asset between a cut/score/engrave.


#9

Yeah but there has to be some kind of color associated with it for it to be picked up. IIRC, anything that was not associated with a color got left behind in AI saved SVG files. (I’m about to fire it up again on a little project, I’ll take a look at the strokes thing once I have these bits cut.)


#10

It shouldn’t error out. It could still classify null - or ignore it. Or give an actual error message. The opportunity for null objects to appear in a design is fairly high, especially for someone new to these programs. Just a click with the pen tool and not following through, or click of a text button, etc all create null (no stroke/no fill) objects.


#11

Okay, I nulled out a couple of lines in the file I was processing and it did just exactly what I expected - the ones that were set to no color were left behind but the file still opened.

So then I nulled ALL of the strokes in the file and dragged it over again and I got this:

So apparently it has to see something in the file in order for it to process in the app.


#12

Okay, @jamesdhatch, I opened your original file in Inkscape, same version you are running I think, and I don’t see a stroke color assigned to the rectangle. Maybe that’s why it’s erroring out.


#13

I don’t know if it’s related, but I have not been able to freshly upload ANY SVG file tonight. Things that I’ve loaded and run a dozen times are erroring out. File previously uploaded and still on the home screen are processing fine to the GUI.


#14

That happened once to me IIRC. Wouldn’t load anything new, but worked for already loaded files.

Did you notify support about it? I think they fixed it the last time. (It’s all starting to run together now though.)


#15

That’s why I didn’t set it specifically. I just left it as a default. I’ve not had it be an issue before. I haven’t checked if the design I was working on has an issue with thick lines (I usually use a hairline or 0.01"). If that’s a problem with the GF it’s a new issue.


#16

i saved the file in your OP, opened it in illustrator, saved out as an SVG, then loaded in GFUI and it opens fine.


#17

From all the posts here and in another similar thread, it looks like AI produced files are unaffected.


#18

yup, that’s where i was going with this. seems like someone has pinpointed the odd/even rule again, so something in the GFUI import has probably changed and now doesn’t like how other programs write that portion of the SVG code.


#19

Yeah, it has to be something that changed on the GF as files that have worked for months are not working now. Hope support gets this fixed very soon.


#20

Try again, folks are getting them loaded now.