Unexpected error with NEW uploads only


#1

Any of the files already inside the GUI will load.
Any NEW uploads (even the ones that have previously printed) cause the basic error message.
I think it flashed once as error 401 but so fast I am not sure.
Chrome data and cache tossed. No good.
Another browser used. No good.

Until this is fixed I am only able to print the designs that remain on the https://app.glowforge.com/ page and I do not keep many on that page.

Kind of a PITA. Your https://statuspage.glowforge.com/ status page says the system is functional, but from here I am not seeing it.

image

EDIT - since 401 is authentication, then is a security test failure? Already had to relog when tossed the data cache, so still looks to be on your end.


#2

Did you try loading a second time? This happened to me last week, and if I loaded the design a second time, it took it 100% of the time. There were a few other issues I had as well, that all started the same day (Wednesday I think). Didn’t use my forge all weekend, but come today all those issues were gone.


#3

Mine is also doing this. Can’t load a new design…


#4

This is exactly the scary part of all processing being done offsite… I can no longer use my Glowforge…


#5

Guess the take from this is to leave the stuff you do a lot of ‘on’ the APP page.
Just did some designs already on the page, so that works fine.

Trying to keep that page tidy was a bad idea (but it did prevent scrolling scrolling scrolling down to try and find the design wanted again in all that mess).

But still no Upload and I spammed the hell out of the new file I wanted to try out.


#6

This is happening to me today too. Any new .SVG file uploaded generates the unexpected error. I’ve tried different files saved in different software (Inkscape & Affinity Designer). Even a simple circle fails to upload.


#7

I had a problem this morning. I kept making sure the file was ok in Inkscape, I made sure there weren’t any double lines, then I made sure the file was flat. After I kept having problems, for some reason I checked to see what the actual size was - for some reason Inkscape had saved it as 135 inches wide! I resized it and didn’t have issues after that.


#8

Doesn’t explain upload of designs already printed but not loaded in the App


#9

I seem have the same problem, only existing files already in the menu open but new ones will not. Also if an existing file is opened ‘add artwork’ has the same problem.

Everything worked without issue yesterday.


#10

I’m completely opposite. I can upload new designs with no problem, but if I try to pull previous designs I’ve cut from the library, it acts as though its loading, then nothing is there.


#11

It is showing a 401 error now and again.
Saw it a few more times and could read it before it blinked off.


#12

I just uploaded a new SVG file design and while it look a little while due to the file size, the upload worked without an issue.


#13

I have no words to express how pleased I am that you managed to upload a file.


#14

I just tried uploading a simple SVG again, but from a different computer, different network, new file, and still no luck.

Concerning file size, 572kb. Maximum length of a line in the SVG is simply 71mm. It’s not a huge design and not a massive file size.


#15

I suspect that since this does not seem to be a wide-spread issue that you may be looking at local network or internet issues leading to the connectivity. The Glowforge application has been working flawlessly for me today. It usually gives me a 401 error on login, but that isn’t happening today.


#16

New piece of the puzzle. I cannot load svg’s but i just loaded a jpg with no problem.

I tried two separate PC’s, logging off the GF account each time. Different browsers as well. Consistently cannot load any new svg’s but was quite surprised that I could load a jpg file.


#17

Nice catch.

I CAN load PDF files.
If this is not resolved soon I will just resave the designs I want as PDF I reckon.


#18

How does a design saved as a PDF work? Is it just engraving like uploading a JPG or PNG is? Does multiple colors for different settings work?

If this upload issue doesn’t resolve by tomorrow I’m going to need a plan B to get some work done.


#19

PDF is just another lossless file protocol type.
SVG, PDF EPS, and many more. Even to a point STL DWG and DXF and other CAD flavors.
A lot of the choices depend on the file filters of the program chosen because a protocol assumes it has basic structures and calls, but most programs also add in specific tidbits to help//assist their particular program (which sometimes do not allow other programs to interpret it correctly).

ANYWAY - PDF does work. Just resaved the file that started all this as PDF. Then tried one more time as a SVG.
When it failed, I uploaded the PDF instead and it banged right to the machine.
Good there is a work around but this is still a serious problem.


#20

I ran the the GFUI in a Chrome session in debug mode and captured the following screen shot at an exception condition. Hopefully this may help the support team.

https://drive.google.com/file/d/1_oGG9VXXdRPtWE0yuLRpyeBD2Oua-MWc/view?usp=sharing

On the home page I simply went to upload a very small previously used SVG file. Chrome stopped at this exception point and when I continued the session the exception was hit a few more times (retrying I suppose) before the fatal error is displayed.