Unfinished cut path?


#1

Just had a weird issue where:

  1. on the settings panel (left side), the thumbnail image of my file appeared correct and complete.

  2. on the bed image/preview, only some of the paths were drawn.

  3. I told it to cut anyway, and in fact only the fully-drawn paths were cut. So the preview was correct.

Um, why? The original source file is a DXF, so there are quite a lot of individual paths in the file, but I’ve cut more complex images before without issue. Interestingly, the smaller gears were cut first, so it doesn’t seem like I just ran out of memory at the end or something…

Screenshot:


#2

Quick update: I just finished cleaning my lenses (nasty flareup when using Woodpeckers BB ply so I got worried about debris), and when I turned the unit back on (sans material on the bed), I’m now getting this:

…the settings panel renders are all wonky, and the bed/preview images are different than they were before.


#3

Most common cause of incomplete cuts on complex files, (and gears with that many nodes can qualify as complex if they haven’t been simplified), is not waiting until the pink preview has completely rendered on the screen before sending the item to Print.

I’ve had complex files that took ten or fifteen minutes to completely render in the preview, and if you send it to cut before it’s done, you will lose parts of the file.

You’ll need to close the file, open it again, and let it finish the preview before sending it to print.


#4

I actually think they have another bug. Happened to me last week as well, i just haven’t had time to come back around to it and play with it more.

File lit up like it was going to engrave the mouth of this sugar skull (Happened on 2 different skull files). I had several layered as I was using a jig, so that’s what you see here. You can see the teeth and area around is set to engrave

First time I ran it, I ran it and went about doing other stuff, came back and the whole mouth was missing. I chalked it up to exactly what you said, so I set it to run again, this time waiting for the render to show, and this is what I got.

Restarted my computer, restarted the GF, did a quick check of the file and tried again. Got the same thing, Even waited for multiple passes of the render, just cause. It did the same thing on another sugar skull file. Been too busy to come back an dig deeper, but it’s on my list.


#5

Is that a vector file?

If so, I’d try rasterizing it. One reason it might not be picking up the mouth could be overlapping vectors. (Might not be the reason, it’s just a guess without actually taking the file apart to see what’s going on.)


#6

It is a vector. It did the same thing when it was the only thing in the file. So did the other one.

This was just for fun. Once the the work on the GF slows down I’ll dig and see what I can find, I just chimed in because it wasn’t an isolated incident.


#7

Problem is, there are a couple of different things that can cause it to happen.

The most frequent cause is to just not give it enough time to load. (People do get impatient and I’m no different - i’ve done it more than once.)

But issues like having nodes or vectors that overlap in your design can also cause it…it’s just not as easy to peg that one without checking over the file design carefully.

When you get ready to take a look at it again, tag me. I wouldn’t mind taking a look at it. I know the interface can handle files of that complexity, so there has to be something going on in the file that makes the mouth area different from the rest of the file. It’s not actually enclosed inside the skull, so maybe it got left behind during a move. I’ve had that happen too, and it’s hard to see it when it’s grayed out. (You can draw a different colored rectangle around everything to use for grouping it, and then just set that rectangle to Ignore when you go to process it.)


#9

Unioning that into one giant path would probably help as well. Of course that won’t work if you want different engrave settings for the teeth vs surroundings.


#10

Thanks for all your help @Jules.

@martin.anderson I’m so sorry your print didn’t include all the pieces you expected.

I took a look at your design and found that while the lines that make up your shapes are grouped together, they aren’t actually joined as a single shape. There are a few ways to resolve this:

  • Open your design in design software and join the individual lines into a single shape
  • Use this quick trick to join your design
    1. Draw a box around the design. Give it a stroke that is a different color than the rest of the design.
    2. Upload the design to the Glowforge app and open it. The design will open, but everything inside the box will be grouped.
    3. Set the box to be ignored in the steps bar and configure the settings of your design as you wish.
  • Wait for the entire design to load before pressing print
    • In the past, this issue has occurred when people pressed “Print” in the app before the design had fully loaded. To avoid this in the future, make sure to wait until you see all the elements of your design appear in pink before pressing “Print.”

If these options don’t take care of the issue or if you have another question, please let me know.

I’ll also look into why your design loaded with the unexpected black shapes in the thumbnail.

@curt

I actually think they have another bug. Happened to me last week as well, i just haven’t had time to come back around to it and play with it more.

We try to keep to one topic per post in the Problems and Support section. If @Jules suggestion didn’t fix the issue for you, can you create a new post with this question?


#13

@martin.anderson
Thank you for your patience.

After looking into the issue with the thumbnails further, I believe the solutions I provided earlier for the print issues will also help here.

If you don’t mind, would you also provide a bit more information for us by doing the following:

  1. Open the Windows menu and search for “System Information.”
  2. Select the “System Information” app that appears in the search menu. A new window will open that displays information about your computer.
  3. Screenshot the data listed there and send it to support@glowforge.com.
    • Mac: Press Shift-Command-4 and click and drag a box around your image. You’ll find the screenshot file saved on your desktop.
    • Windows: Click on the Start Menu and search for the Snipping Tool. Open the Snipping Tool > New then click and drag a box around your image. Click the Save icon and name and save your file.

Thanks!


#14