Upgrade To Premium

:frowning: e are on a trial for premium which is ending in 3 days.

Every time i click on upgrade to premium it just takes me back to the home page?

I have tried on multiple browsers and on my phone and i can not sign up.

I have also emailed 3 times and not had a response.

Please can someone help :frowning:

Given what you’ve already tried, I doubt there’s much else you can do except wait to hear from support - they do not monitor or participate in these forums.

6 Likes

Welcome to the forum.
Something odd that I have noticed over the years is that the browser I am using influences my Glowforge account. Just this minute I clicked on “manage my subscriptions” while in Firefox, and nothing happened. Clicking on the same tab in Chrome takes me to a page that shows my Premium price and other details. Try upgrading to Premium while using a different browser.

7 Likes

It could be something about your home network setup maybe? If your phone was on wifi at the time that would still be on your network. Might be worth trying it on the cell network by turning off wifi and see what happens.

If you have some whole house firewall rule or something like a pi-hole or other proxy it could maybe impact this. To be clear: this is a very longshot, but may be worth chasing down just to be thorough.

5 Likes

Hey,

Thanks for the tips, i have tried it on Firefox and chrome and having the same issues.

I also tried it on mobile data but still no luck.

Has anyone successfully done it on either one of the above browsers?

When I click on the upgrade option in Chrome (my default browser), Firefox or Safari, it takes me to a series of dialogs to enter personal and credit-card information.

2 Likes

Could you paste the URL link to that page?

I think thats the problem…the URL isnt actually taking me anywhere.

Is it allowing you to login? It almost sounds like it is not properly logging you into the account?

yep im all logged in fine. I can use the app with no issue.

I think there is a deeper level. One for using your Glowforge and another for where money is needed. If you try to go to the catalog it might get you to that point. And all the things you can spend money on are there, including buying a glowforge.

1 Like

Blocking third party cookies maybe? Or have an ad blocker? Hope you get it resolved.

1 Like

There is no specific URL, I am just clicking the “Go Premium” button at the top of the dashboard or within the GF UI itself - same result, brings up the dialog I posted, which is the first of several.

image

NOTE : If this window fails to open, confirm your browser is set to allow pop-up windows, then try again.

This note is on the FAQ page for Premium. Certainly worth checking…

Good luck!

9 Likes

This topic was automatically closed 32 days after the last reply. New replies are no longer allowed.