Upload Error on all new files

Suddenly getting upload errors this evening. Everything worked fine all afternoon.

Screen Shot 2021-02-08 at 9.10.48 PM (2)

I have:

  • Restarted the Mac
  • Cleared the Browser Cache
  • Tried both FireFox and Chrome (Latest versions)
  • Restarted the glowforge
  • Tried different files including ones uploaded previously.

I can open and run existing projects and I can create a blank project. If I open a new project and try to upload from there, I get the same error.

I can also upload via the web to Dropbox.

Hello there @shogun - I’m sorry to hear you’ve run into this trouble, thank you for reaching out.

Would you mind sharing a couple of the files that failed to upload with me so I can see if I have any issues on my end? It’s certainly odd for this to be cropping up with designs you’d been able to upload previously.

The problem has mysteriously stopped this morning and I was able to upload. I am assuming it was a temporary server side issue (capacity or network). Is it possible to provide more information in the error messages?

As it stands, “There was an error with this file” leaves the user with the incorrect impression that something is wrong with the glowforge itself. This leads a user to waste a considerable amount of time and frustration spent trying to diagnose a problem that is not on their end.

A simple “The server attempted to upload the file but an error occurred.” and provide an error code for both support and the user. I know you want to keep the interface friendly, but making it a black box is just frustrating.

I am glad to hear you’ve had success since reaching out.

We appreciate your feedback regarding the error messaging, and are always on the lookout for opportunities to provide our users with accurate and useful information when it comes to notifications in the app. Thanks!

I’m going to go ahead and close this topic since you’re up and running now, but feel free to reach out at support@glowforge.com if you should experience any further issues.