Upload error with PDFs


Ever since my photoshop updated to 2022 I am unable to upload PDFs into GF. I use actions and have not changed anything on my end. I do notice that before the upgrade my PDFs were around 500 KB and now they’re 4000-5000 kb with same resolution and actions. I have updated my browser and cleared cookies etc and also tried another browser. I’m not sure what else I could be doing wrong and i’m not the best with photoshop but just use it for the same actions.

Everything else I do will upload just fine in GF and I tried transferring the images to inkscape and saving as SVG but that hasnt worked. Also uploaded older PDFs just fine that were done before the upgrade.

Thank you in advance!

You need to check your export settings and decrease the number of extra elements that are retained in the PDF background, for use editing later. try turning off one element at a time, save the PDF, then examine the file size when done.


I did try this under export as ? and it didnt give me much to change ?

I’m sorry for the trouble when trying to upload some of your designs. So that our team can look into this further, may I have a copy of one of the PDFs which isn’t uploading to the app? If you’d prefer to share it privately, you can email it to us at support@glowforge.com.

Thank you! I have responded to your email and was able to attach the pdf

@alexnaff08 Thank you so much. I’m going to go ahead and close this forum post and follow up with you there.