Uploading files

I’m having problems uploading files into the GFUI.
The first time I upload a file it shows up ok in the GFUI. If I delete the file in the GFUI and then try to bring it up again no image appears.
Closing the browser and starting does not help.

What do you mean by try to bring it up again? Are you re uploading the file or selecting undo after deleting?

Re uploading file

If you delete it, it’s gone. You will have to upload it again.

Have you tried to clear the cache on your browser? and then re upload.

1 Like

That’s what I’m saying. I delete the file and then upload it again. Any file that I have uploaded will not upload again after I have deleted it in the GFUI

Yes I even tried a different browser.

1 Like

Strange, what if you change the title of the file? Not sure if that will do anything but its all i got hehe

Files that I have on my computer I can reupload.
It is files that are in my Dashboard (that I do not have direct access to) that will only upload once.

If you delete them from within the GFUI, they’re gone. It’s not like any files you have purchased from GF, which you can reload. You have to upload them again from your computer.

1 Like

So, by “upload,” most people mean “transferring from my computer to the server.” If they’re not on your computer, you’re not re-uploading them. It sounds to me like you’re trying to re-open them from your file library (the list of files you see at app.glowforge.com). But if you’ve deleted their contents, then all you’re going to get when you re-open them is a blank file.

If you’ve deleted a purchased file, you can reset it by going to “design details” under the 3 dots icon in the menu bar, but if it’s a file you previously uploaded and no longer have on your computer, once you delete it from the interface it’s gone. :frowning:

1 Like

I’m sorry that you are having issues with uploading on the GFUI. Thanks for letting us know. We need a bit more information to investigate. Please do the following:

  1. Go to https://www.whatismybrowser.com/
  2. Look for the header that says “Your web browser’s unique URL”
  3. Click the button that says “Copy URL to Clipboard”
  4. Reply to this, and paste in the link provided

Could you please send or post the file you’re running into trouble with?

This will help us understand the circumstances around your error so we can work on it for you.


I couldn’t find a button that said copy URL to Clipboard so I pasted it above.
I am having the problem with any file that has been saved in the dashboard. If I upload a file from my computer it loads fine but then if I delete it from the GFUI and then try to upload it from the dashboard it does not upload. This problem seems to have started after I uploaded the 51 files from the Free with Premium yesterday. It is happening with any of the 51 files I uploaded and it is also happening with my personal files also

If you upload “myfile.svg” and go straight to the GFUI and then delete the contents, then the dashboard still has “myfile.svg” so when you try to load it again it hands you the file on the dashboard which is now empty.

Now you can drag and drop that file back into the open GFUI or delete the reference in the dashboard and load as usual.

OK I found it. It’s Design Details and then Reset Design.

1 Like

Thank you for the update that using “Reset Design” restored the designs which you got from the Glowforge Catalog. Are you still running into trouble with the designs that you created yourself?

1 Like

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.