Vector Object Error with Rotation


#1

So working on some time sensitive projects and I found a weird error with vector objects. I’ve created some stacked objects in Illustrator, check to make sure there’s not any stray points or lines, and got ready to engrave. This is what it want engraved:
18E7_vertical

However, after rotating in the GFUI I get a band that’s not there:
18E7_horizontal

Has anyone seen this before and is there a fix? I guess I could try rotating my materials (maybe too big) or my design in Illustrator, but I feel that this is software error with the GF.

Thanks in advance!
Matt


#2

Any open paths?


#3

I’ve had at least 2 different files get stray engrave lines. (With no open paths ) GF support confirmed they are seeing the issue and are looking into it, but I’ve heard nothing past that.


#4

I would vote for open paths as well. If you upload the design we can take a look at it.


#5

Yeah, I’d say so too. Normally that is caused by open paths in the design. (Your vertical alignment also has an issue if you look at the tip of the shield…no point.) If you’re in a great hurry, rasterize the object at high dpi (600) before you engrave it. Should eliminate the bar without having to hunt it down.


#6

GF_18E7MSgt

Here’s the file. The tip is still there, I just screen captured too early.


#7

Okay, just pulled that apart, and you have three copies of the same file with different numbers in them overlaid exactly, and they are all the same color fill, so the interface is going to treat all of them as one single engrave, if it processes.

Switch the fill colors for two of them to something besides black - that might work. That should give you three separate engrave operations.

You will want to turn it on it’s side - it’s just a hair too large for vertical alignment and it will take a long time to process. You can speed things up a lot if you use the SD setting, not the HD setting.

That ought to at least get it to process. If it still hangs up, take the LPI down to 225 from the SD setting.


#8

No open paths :slight_smile:

FWIW, yes, you uploaded the file with multiple layers in it… after hiding the two so it matched your image in the first post, rotating in the UI, I get the same line showing up in the print preview. I actually rotated it clockwise, vs your counterclockwise and saw the error replicate in the same spot relationship wise (through the 4 - so it would be on the bottom).

I haven’t broken down the file all the way, but I think you have a problem with the number 4. Just on a hunch, when I isolated the compound path and went into it, I had to delete something like 5 copies of the counter inside the 4 to get it to disappear. Once I deleted the counter in the number 4, it looked ok in the print preview (with or without rotation).

Since it’s time sensitive, I’d rasterize that thing and get it done. If later you want to try and figure out what happened, I’d start with that number 4. Edit - I don’t know if it’s a Glowforge problem or a file creation problem - but it’s the 4 that is causing the problem.


#9

Ah, didn’t check for that extra copy, but I got an inlay to cut just fine (left out the small insert parts for the picture). Odd.

Thanks!


#10

I don’t know if this was the problem or not, but nodes stacked on top off each other can create random lines. It appears the UI interprets them as open paths even if they are closed. The duplicate/stacked nodes just seem to confuse the UI.


#11

Thanks for the help, all! I’m glad to hear you were able to get this resolved. I’ve let the team know about the problem you ran into - thank you for uploading the file and including the screenshots.

I’m going to close this thread, but if you run into any other trouble please open a new topic. Happy printing!


#12