Weird behavior at start-up (new GF)?

I had the same thing happen once. Just once. (As far as I know. I don’t watch it startup anymore.) It was the very first time I’d turned on the machine. Everything lit up, I smiled, everything turned off, I sulked, everything turned back on again, I worried. But it never happened again.

1 Like

Thanks for posting about this. I’m so sorry we missed your message.

Is your Glowforge plugged directly into a wall outlet, into a surge protector, or into a battery backup? Or something else?

Sorry, I know @tomn2 opened this thread so your question is probably directed towards him but since I am having the same problem I thought I would respond as well.

I have my forge plugged directly in the wall and I have even tried multiple different outlets around the house and garage to rule out the one where it will be permanently located.

The restarting of the forge in my case happens every single time it gets turned on.

If I should email support directly please advise. Thanks.

You don’t need to e-mail (but you certainly can). But they prefer each issue get its own case so that, among other things, a) they can track issues properly and b) each person gets the attention they deserve. So you should start a new thread here in Problems & Support (or e-mail if you’d prefer).

1 Like

@jaz, I have it plugged into a surge protector (albeit an oldish one). Do you see (or expect to see) different behaviors depending on what it’s plugged into?

FYI the first time I noticed it, I thought maybe a circuit had tripped because I’d forgotten to turn off the space heater that is in the same room but on a different outlet, since I don’t know if the two outlets are on the same circuit or not. But since it came right back on in a second or two (and the heater didn’t change), I figured it wasn’t. I do try to remember to turn off the space heater before I turn on the GF to make sure nothing draws too much power at once.

Fwiw, and probably not your issue, but I had been using my pro without issue for a few months. All of a sudden (after Christmas thankfully), it quit shortly after beginning a job. Not only that, all of the outlets were dead.

I figured it was a breaker. Nope. Plus, the overhead fan light worked.

I cut the main power, got my flashlight and started pulling outlets out. Seems the electrician decided to backstab the wire into the outlets (pushing through little holes to make a connection). Those connections can become loose after a while - and hitting them with high voltage can also cause the wire to jump a bit, which will break the connection.

I pulled all of my outlets on that circuit and rewired them looped around the side screw terminals and it seems to have fixed the issue entirely. Plus, it’s wired correctly now.


Sidenote @jbmanning5 - my first job interview out of college and part of the written test showed a picture of an regular 110 outlet. I was to answer the questions “which is hot” “which is neutral” and “which is ground”. I wrote in the answer “It depends on who wired the wall”. I got the job :slight_smile:


I have this issue as well. Has anyone heard back from support yet? I’m hoping I don’t have to send back my glowforge again.

I have this issue as well. Has anyone heard back from support yet? I’m hoping I don’t have to send back my glowforge again.

@Topher We try to keep to one topic per post in the Problems and Support section. Can you create a new post with this question?

In general, we recommend against the use of a UPS, surge protector, or power strip. The Glowforge power supply has its own internal protection components to address common power quality issues.

Would you plug your Glowforge unit’s power cord directly into a grounded 800 W wall outlet and let me know if it changes anything?

Thank you.

I’m not sure why I would create a new topic. I thought my question was
concerning the topic I posted in. i didn’t see an answer concerning this
issue from staff so I was wondering if anyone got one via email. My
glowforge is plugged directly into the grounded wall outlet.

@jaz, yes I’ll do that. I didn’t remember seeing anything about the choice of plug/UPS/power strip in the manual, so I defaulted to the mid-risk range of a power strip. But I’ll switch it to the wall outlet and watch it for a few days (it may be the weekend before I do much with it again).

Mine is on a power strip (make sure if you use one that the switch on the strip lights - otherwise even if the strip powers things, whatever surge protection it’s rated for isn’t working anymore). Never had that issue with either the PRU or my Pro.

This topic category is basically a support line. The Support staff is likely rated on metrics like that at other companies. One customer to a ticket. If you do not wish Support to address your issue then feel free to comment or linger. But once the OP problem is satisfied the topic will be closed whether or not your issue is addressed. Your choice.


It’s one problem or issue per topic in the Problems and Support area of the forum. If you have a problem that you want them to address with your machine, start a new topic and it opens a ticket that they can research independently.

You can’t rely on the fact that your machine is doing the same thing that this one is doing - it could be caused by too many things. They can review the data logs for each individual machine, to see if the problem that you have actually is the same as the problem for the OP, and doesn’t just look like it from this end.

So if you want them to research what’s going on with your machine - start a new topic in the Problems and Support category. Or send an email directly to . (You don’t need to do both, just one. They both do the same thing, and doing both slows down the response time.)

Anything else and you run the risk of walking away dissatisfied, although I have seen them answer an easy one or two if they actually did turn out to be the same issue. But it’s probably not caused by the same thing, so it’s really best to just post a new topic. :slightly_smiling_face:


Just adding a data point and not opening another ticket. I was seeing this behavior from time to time. When I saw this thread I started to pay more attention at startup and saw it fairly consistently. I was thinking, hmmm, I have it plugged directly into the wall, then I remembered that is not true, I had it plugged into this…

…so I removed it, and have yet to see the issue again with a weekend of forging. Knock on wood!


@jaz I plugged it into the wall tonight, and turned it on. Very first time, it did the short power loss thing again. :frowning_face: Any other suggestions? Also, I’m not sure it was ever made clear whether or not this is expected – is it?

1 Like

My unit was replaced because the LED lights were flickering and sometimes way brighter than they should be. So much so that it would wash out the image in the camera. So, they replaced it with a new unit. This new unit seems to be running fine, but at start up it sometimes will have what appears to be a sudden power failure and then restart. I wasn’t sure if this is normal, benign, or a problem. Any official word from support?

1 Like

I get that one second power off too.

Thanks for all the information! There are several issues that can be responsible for these, ranging from a firmware update, to an issue with building power, to a Wi-Fi issue. It’s also possible there’s a bug - I will make sure the team checks it out.