Weird behavior at start-up (new GF)?

Good point, I will be patient.

Wasn’t sure if someone may have emailed support directly about this already and heard back something. But, I’m sure if that happened they would have posted the answer here.

Mine has been doing the same at startup. It works pretty much flawlessly after that, though. I hope it’s a feature, not a bug.

With this many folks chiming in I am starting to think this is not a bug. Firmware update or the like seems like a good guess. Feeling less angst.

Looks like the last firmware release was somewhere around 11/21/2017 (version 1.2.1-1031).

A firmware update would account for two quick reboots in a row, but not likely to be the cause if this is a (semi) regular occurrence.

I’ve also never noticed the lid lights dim for that long during a reboot. Usually, it is just a quick change in brightness.


Any ideas on what occurs if you have a corrupt download or for some reason the flash doesn’t take? If it fails to flash, I assume it reverts to original firmware version and then tries again on the next cold boot?

I’m barely at setting up my GF, and this is happening to me! :worried:

I’m not entirely sure. It appears that they -may- halt the update process if it has a failure, which would then just retry it at the next boot. In this scenario, it appears that it would continue operating under the original firmware without an issue and retry again later.

If it thinks the update went OK, but the new firmware fails to boot for some reason, the watchdog would trip causing it to boot into recovery mode (PURPLE button).

I may be wrong, but it doesn’t seem like the recovery mode tries to do anything other than upload crash logs. It appears to have the ability to run the firmware updater, but I have not observed it doing that - nor can I find any evidence that they intend it to.

I give a bit more in-depth description of the apparent firmware upgrade process here.

Just my personal opinion - It looks like they reached a certain point in the development and just essentially stopped. There are a lot of half-finished things in there where it looks like someone was expecting they would go back and finish, but then never did. There are pretty obvious issues, and they haven’t been touched, even after several FW updates over the past 6 months.

It is reminiscent of what happens when a portion of a project was primarily the work of one person who then left before it was finished: Others coming in later to pick up the pieces don’t know where all the bodies are buried, and are not familiar enough with the details to know where to look.

Again, just my opinion based on my personal experiences and applying them to what I am seeing in the GF firmware.


Still no word from any GF Staff on this post…

I had the same thing happen once. Just once. (As far as I know. I don’t watch it startup anymore.) It was the very first time I’d turned on the machine. Everything lit up, I smiled, everything turned off, I sulked, everything turned back on again, I worried. But it never happened again.

1 Like

Thanks for posting about this. I’m so sorry we missed your message.

Is your Glowforge plugged directly into a wall outlet, into a surge protector, or into a battery backup? Or something else?

Sorry, I know @tomn2 opened this thread so your question is probably directed towards him but since I am having the same problem I thought I would respond as well.

I have my forge plugged directly in the wall and I have even tried multiple different outlets around the house and garage to rule out the one where it will be permanently located.

The restarting of the forge in my case happens every single time it gets turned on.

If I should email support directly please advise. Thanks.

You don’t need to e-mail (but you certainly can). But they prefer each issue get its own case so that, among other things, a) they can track issues properly and b) each person gets the attention they deserve. So you should start a new thread here in Problems & Support (or e-mail if you’d prefer).

1 Like

@jaz, I have it plugged into a surge protector (albeit an oldish one). Do you see (or expect to see) different behaviors depending on what it’s plugged into?

FYI the first time I noticed it, I thought maybe a circuit had tripped because I’d forgotten to turn off the space heater that is in the same room but on a different outlet, since I don’t know if the two outlets are on the same circuit or not. But since it came right back on in a second or two (and the heater didn’t change), I figured it wasn’t. I do try to remember to turn off the space heater before I turn on the GF to make sure nothing draws too much power at once.

Fwiw, and probably not your issue, but I had been using my pro without issue for a few months. All of a sudden (after Christmas thankfully), it quit shortly after beginning a job. Not only that, all of the outlets were dead.

I figured it was a breaker. Nope. Plus, the overhead fan light worked.

I cut the main power, got my flashlight and started pulling outlets out. Seems the electrician decided to backstab the wire into the outlets (pushing through little holes to make a connection). Those connections can become loose after a while - and hitting them with high voltage can also cause the wire to jump a bit, which will break the connection.

I pulled all of my outlets on that circuit and rewired them looped around the side screw terminals and it seems to have fixed the issue entirely. Plus, it’s wired correctly now.


Sidenote @jbmanning5 - my first job interview out of college and part of the written test showed a picture of an regular 110 outlet. I was to answer the questions “which is hot” “which is neutral” and “which is ground”. I wrote in the answer “It depends on who wired the wall”. I got the job :slight_smile:


I have this issue as well. Has anyone heard back from support yet? I’m hoping I don’t have to send back my glowforge again.

I have this issue as well. Has anyone heard back from support yet? I’m hoping I don’t have to send back my glowforge again.

@Topher We try to keep to one topic per post in the Problems and Support section. Can you create a new post with this question?

In general, we recommend against the use of a UPS, surge protector, or power strip. The Glowforge power supply has its own internal protection components to address common power quality issues.

Would you plug your Glowforge unit’s power cord directly into a grounded 800 W wall outlet and let me know if it changes anything?

Thank you.

I’m not sure why I would create a new topic. I thought my question was
concerning the topic I posted in. i didn’t see an answer concerning this
issue from staff so I was wondering if anyone got one via email. My
glowforge is plugged directly into the grounded wall outlet.

@jaz, yes I’ll do that. I didn’t remember seeing anything about the choice of plug/UPS/power strip in the manual, so I defaulted to the mid-risk range of a power strip. But I’ll switch it to the wall outlet and watch it for a few days (it may be the weekend before I do much with it again).

Mine is on a power strip (make sure if you use one that the switch on the strip lights - otherwise even if the strip powers things, whatever surge protection it’s rated for isn’t working anymore). Never had that issue with either the PRU or my Pro.