Weird inkscape issue - Can't drop photos or SVGs into window

In windows 10…

So I upgraded Inkscape and suddenly dropping images and svgs into an open Inkscape window didn’t load them into the svg. “Import” worked fine from the menus but the drag-and-drop method failed silently.

I was pretty sure the upgrade had broken itself, but as it turns out it had to do with how I was running Inkscape. After the install, it asked “do you want to run Inkscape now”, and I said yes. Apparently, this causes Inkscape to run with elevated permissions, since the installer was in turn running with elevated permissions.

As it happens, running Inkscape with elevated permissions prevents drag and drop file loads. Who knew?

These guys did:

Restarting Inkscape as a normal user solved the problem.

So, something to remember when this happens to you.


I’m glad you got it sorted out, I always import with the home page because I’m anal version control.

Home page? Not sure I know what you mean.

Well thanks for the heads-up, I’ve been thinking about installing the new version. Do you need to uninstall the previous or does it overwrite?
I wonder what improvments it brings?

From the render page I click “home” then “upload”, I’ve always done this because each iteration is saved as a version.

I used the exe installer, and it asked if I wanted to uninstall the previous version. It also asked if I wanted to keep my preferences etc, which I did. My default template, color palette, and preferences saved no problem.

It went fine, except for the running at elevated permissions thing. Just say “no” to the launch option, and manually start it instead, no problems.

1 Like

Oh no, I mean dropping SVGs into Inkscape, not into an existing glowforge UI window.

1 Like

Oh!!! My bad!


This topic was automatically closed 32 days after the last reply. New replies are no longer allowed.