We're sorry, an unexpected error has occurred - repeating


#1

I am running into this error all the time when I load a design. The UI pops up, shows the error, auto-refreshes, shows the error again, and repeats. It does not seem to happen when offline, just when online. It happens on lots of different designs, including one I did today that was just 3 rectangles created in inkscape.

This is seriously compromising my ability to make cuts; it happens repeatedly when I’m trying to make any changes. How can I track down what is going on?


#2

You can post one of the problem children up here for a peer review to determine if it may be a file problem.


#3

Okay, here’s a really simple one.

Charging%20station%20felt


#4

I see a couple of things with it…you have overlapping vector paths at the sides of the center rectangle, and they are the same stroke color. That confuses the interface. (And will result in a double cut.)

Also, (and I don’t know if it will affect anything or not), but the rectangles extend across the boundaries of the artboard that you set up. You might want to copy that into a new file with an artboard of 20" x 12", (508 mm x 304.8 mm if you prefer to design in metric), and delete the two sides of the center rectangle. (Just leave the top and bottom paths, the sides of the center will be cut out by the rectangles on either side of the center one.)


#5

I found out the hard way that not making everything “set to path” would cause that error.


#6

Can you tell me more about what you mean by “set to path”?


#7

Yes, I did it quick and dirty as a test. But when I actually got the UI to behave, it cut fine. Which is the same experience I’ve been having on other designs. Here’s another one that has been problematic; can you see if anything jumps out at you?

Horse%20-%20Major


#8

Hmmn. That one looks fine, and it rendered without any problem.

I wonder if you’re not having intermittent WiFi issues or something along those lines? :neutral_face:


#9

I am literally 20’ from my router when I’m using my glowforge, so I don’t think it’s a WiFi issue.

I’m thinking I might grab my video camera to capture the behavior that I’m seeing.


#10

If you have any primitives that are not ordinary paths the GFUI will error out. This drove me crazy (a short drive in the best of times) trying to figure out why I was getting that same error when a very similar design did not. Finally, I realized that the one causing the error still had the offset in place so I selected everything and set them to path via…


and after doing that everything uploaded fine. several times since I have had that error and appied the same treatment that fixed it