Whats wrong with glowforge network?

is there anything wrong with the GF network connection/server? I cant get anything on my interface to work, its extremely slow and I have rebooted, tested network connections and everything I know to figure it out…I am trying to finish two jobs and this is horrible…It wont move , resize, or do much of anything on the interface. I have been trying for over 2 hours to start a job that should take no more than 5 minutes to set it up…

Glowforge Status page
says everything is operational… maybe it’s your connection?


Try closing and opening your browser after clearing the cache or try a different browser. Status of the interface for me today was normal.


No issues here, sorry.

The app doesn’t even require an internet connection to manipulate designs. Of course, it does to upload or start a print.

1 Like

Absolutely nothing on mine worked this afternoon no matter what I did. Initially got stuck on centering and then couldn’t get anything to happen. Couldn’t even connect to the Glowforge WiFi when trying to redo the setup. Then couldn’t get the set up site to work or load.

connection shows 98mbps, its got to be the server we are connecting to…they have got to get this software standalone ……I have dozens of customers that are expecting product and cannot let this happen. I will look into it further , but 95% sure its a problem on the other end, I can verify all my connections here, every other site I check works fine…

They’re not going to change the software to standalone. That’s been clear from the get go. :slightly_frowning_face:


Well, I guess the only good take away from being pissed off for several hours trying to get this working is that I was not alone and likely not my issue? Hoping it is up and running this afternoon then.

Out of 20k plus users just a few having issues probably confirms that it is your issue. Clear your cache - or try a new browser. Literally the system does zero talking to the :glowforge: network during resizing etc. on the interface, that’s all your browser.

I’m so sorry to hear that you’ve been running into trouble utilizing the Glowforge App.

Could you try opening the app from a different browser like Google Chrome, Firefox, Apple Safari, or Microsoft Edge?

If that doesn’t help could you please do the following:

  1. Go to https://www.whatismybrowser.com/

  2. Click the link underneath “Share my system info with tech support”

  3. Copy the highlighted link

  4. Reply to this, and paste in the link provided

This will help us understand the circumstances around your error so we can work on it for you.

I will do that Shelby. I am so very sorry I was a bit freaked out last night because of deadline and should not have be so quick to point the finger. It might have been a file on my computer I was trying to load? not sure what it was at this point. I was frustrated and should have reached out for help rather than getting angry.


I tried multiple devices and different WiFi sources yesterday including my home WiFi and cellular too with no luck. Came out today and did nothing and it came right on and is working fine. Glad it is up, but tells me it was not my issue.

We haven’t heard back from you but it looks like your Glowforge is connected and you’ve been able to print since contacting us. That’s great!

Could you please let me know if you’re still experiencing any problems?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.