White Screen of Death

Hey everyone! So when we are trying to make a design. Any time we try to put a outline on the object our entire screen goes white and won’t fully load. We have to reload the page completely. When we do the outline is there but if we try to select and move it to another part of the screen the screen goes white again. We have tried this on 2 different computers with the same result. What is going on???


I’ve been experiencing the same thing since last night.

hey I am having this same problem which just started this morning. Did you find a solution?

works fine here for me (edge chromium)

I cant use the text feature
when i select text the screen goes white

I am now having this problem this morning when trying to use the text feature

just tried the text feature in google chrome (after trying the outline feature in edge chromium). both work fine for me.

have you tried clearing cache in your browser?

1 Like

You’ve opened a support ticket by posting in this section, so they’ll be along soon to help out. To save some time, because they’re going to need your browser info, go to whatismybrowser.com, copy the link it gives you there, and paste it here.

Hmmm. It’s working fine here. https://whatismybrowser.com/w/35MZ69P

WhatIsMyBrowser says my browser is out of date – maybe a browser update broke it?

I’m having the same issue. I have google chrome and it said i needed to update my chrome. I did, but I’m still having the same problem. I have also cleared my cache and refreshed the browser. Still having the issue…

I’m on safari and it’s still happening. I can create the outline, but if I try to move the image (or text) or if I try to resize it, the app immediately shuts down to a white screen. As soon as I click on the image the white screen pops up.

It’s interesting, it doesn’t happen on every file/situation, but I have a reproducible test case here: upload the attached SVG, open it, and click the Insert Text button in the toolbar. It should crash immediately.

Funny enough, that will leave two text objects in the design, one of which makes it crash and the other doesn’t.

white screen trigger.zip (66.6 KB)

Me too! It started last night for me. But it happens when I click on the text.

I’m so sorry for the trouble! The team is looking into this now and I’ll follow up as soon as we have an update.


@sarahbc1991 could you try again and let me know if you’re still experiencing difficulties?

Thank you for bringing this to our attention. All issues related to this are now resolved. I’m going to close this request. Should any new issues arise, please start a new post or email us at support@glowforge.com!