Why does my 121k jpeg take so long to upload?

This is my first attempt to upload a jpeg. Perhaps I am doing something wrong? Hit the upload button and selected my file (made in photoshop). Got an “uploading” dialogue box that never seems to complete. That size file should take seconds…

Drop the file here and one of us will check it for you.

1 Like

Might be a wifi issue. The machine is very picky about a stable strong source. Search on here to find many stories about that.

1 Like

Sometimes, when I have a file that seems to be stuck loading, I cancel the print, and then pick the file again and it loads right up. It seems to happen alot (to me, anyway) and this has worked every single time.
Your mileage may vary.
(My Glowforge is about 8, unobstructed feet away from my router)

1 Like

The image is not being uploaded to the machine, but to Glowforge’s servers in Google Cloud Platform, so your Glowforge’s wifi is not at issue here. All that gets sent to the Glowforge is the movement plan the servers calculate after you hit “print”, several steps separated from uploading an image to the app. Restart your browser, or try it in another browser.


Interesting… I tried to upload it to you as a response, and it just said “processing…” forever. never completed the upload. I can open the file in preview, and I can email it to myself just fine. Is there something going on with the glowforge server?

This forum is hosted by a totally different company (Discourse) than the GF app (Google). The problem appears to be your browser.

1 Like

Fair enough. I will try Firefox

Depending on many things a 121k Jpeg could be considerably larger. I have also seen more than a few times when the transfer did not complete so it never comes to an end. I would bring it up in a raster software and re-export it as a png and that will likely heal such issues.

Hmmmm. Safari failed, but Firefox succeeded???

Some time ago, Safari would not work well at all, so I switched to Chrome specifically to use with my Glowforge. I’m betting that Safari has been updated since that time, but there’s no reason for me to go back. I still use it for other things…but, not for Glowforge.


I’ve used Chrome pretty much exclusively for many years (long before getting my GF), and rarely had an issue with the GF UI. I have Gbps broadband but sometimes, very rarely, I might get a glitch with an upload, just back up and try again and it’s fine.

Some have reported they use Safari, some use Firefox. Your issue was possibly just one of those momentarily glitches.

I’m a new owner of a pro, soon to be delivered but I’m an old retired NE. Bandwidth is a finite entity. Everywhere and with covid keeping people at home they’re chatting on numerous bandwidth hungry applications… When load increases on any circuit, load balancing occurs. You will see it as buffer. Its a way of sharing the available bandwidth as the load increases and decreases. Try not uploading or downloading during morning and evening peak hours. As the other person said, stop a stalled download and restart, sometimes that’s all it takes.

1 Like

Which raises a question now. Is there a minimum upload speed? If my download is 100 and upload is 10 mbps, it will take ten times as much time to upload. Might have to increase to 400 down and 20 up fiber to the house.


10Mbps up is more than sufficient.

The OP’s issue was a glitch, or a problem with Safari.

I know for a fact that 1.5mbs upload and download is not a problem. I had DSL at that speed when I first received my Glowforge 5 years ago. But it was always rock solid and never varied. Ping times were also low and consistent. There were only 8 homes on that DSL switch.


I know that for years there exist copy machines that will detect currency and refuse to photocopy it. Maybe there’s a browser feature that does the same thing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.