Won't cut proof grade leather all the way through

I tried cutting Glowforge proof grade leather and it didn’t cut all the way through. I cleaned all the optics and still didn’t have any luck. My material is sitting tight to the bottom tray. Not sure If I am missing some settings?

I had to use a knife to finish the cut. Engrave worked fine.

1 Like

Because leather is natural material and no two hides are even,it is probably the piece. Just turn lower the speed with a few ideas and it should cut it just fine. I cute leather with mine i use vegetable tanned leather (none proof grade) but i use the settings for thick natural leather, and i even lower my power up to 67-70, and it works beautifull,i dont even need to use masking


I run a 2nd cut line at a slightly higher speed to get those last connections. Leather is a PITA but it’s so worth it!

1 Like

I’m so sorry for the trouble.

Could you let me know about when that print was? I’d be more than happy to take a look at the logs for that print and see what I could find out.

Could you send a photo of the back of the print? That would help with my investigation.

If you’d like to verify your Glowforge is working as expected, you could try a test print on some other Proofgrade material. But if all your other cuts are working fine, it may just be an issue with that piece of material.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.