Won't Print...?

So I’m trying to run a print with lots of engraves and cuts, but I’ve done it dozens of times before (dice towers). When I click Print, it goes to “Preparing your design” then “Scanning material”… then nothing; the popup window disappears and I’m back in the UI with the option to start the print again.

Will the print dialog appear when you try to do a less-complex design?
If so, have you changed your engrave/cut settings since the last time? Maybe in such a way that would push it over the buffer limit (~3 hrs)?


When the pop-up window disappears, clicking on the Print icon again has usually brought it back for me, still ready for the same print job.

1 Like

The print dialog always appears, but with this particular design it crashes. I’ve tried a smaller print and it goes through.

I haven’t changed any settings, only placement to utilize scraps last time. I’ve used this file without changing settings dozens of times before… until yesterday. The print run time is usually about 2-2.5 hours.

Nope, it crashes. The top right reads “Ready” again after the crash.

Hmmm… Maybe try copying the design. That is, click the chevron then “Make a copy.” Then, with the copy (so you don’t mess with your original), adjust your settings a little bit. Try dropping your LPI a level and see if it runs and what that runtime will be.

Also, just thinking, maybe you’re using a different material than last time? A material that, by default, has different settings associated with it?

1 Like

Hmmm, so I tried it again to test and now it’s working. Maybe just a server/connection issue? No changes made… =P


I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at support@glowforge.com. We’re here to help!