Word clock based on cheaper led matrix

I am trying to get this to work, but am having no luck at all.
I am using

Adafruit Pro Trinket 5v/16Mhz
DS1307 RTC
Adafruit NeoPixel 8x8

The code compiles fine. But it will not upload to the Trinket.
I get this error

avrdude: usbdev_open(): did not find any USB device “usb” (0x03eb:0x2104)

I have tried two different Trinkets and RTCs
I have tried using a Mac and a PC, but always the same error.

Any ideas ?

Thanks

Dammit! I’ve needed exactly that for so long. Why didn’t I check Inventables?!?

1 Like

What are you using to compile/develop in?

follow the tutorial https://learn.adafruit.com/introducing-pro-trinket

uploading via tinyusb is tricky but the tutorial will help sort it out. avoid usb 3.0 port if possible

I finally got the code to upload using the FTDI option.
The USB upload option does not work using my MAC or PC.

the upload to trinket pros can be tricky but it does work in windows if you load the adafruit drivers and avoid usb 3.0. I upload a trinket on average twice a week. it gets worse if in trying, one crushed the existing bootloader. Then one has to jump through at least 7 flaming hoops of fire. When I hit that point (rarely), it is easier to chick the trinket vs fix.

It’s a cool product and check out the black over glow-in-the-dark acrylic too. So much fun!