Yellow button of death! Need Help!

I was printing a short project yesterday 4 ornaments when the Glowforge just stopped working. I took the printer head off to check the white belt and when to put it back and completely forgot that the glowforge was still on. There was a slight spark when the metal touched.

I’ve tried everything and still nothing. I tried wifi issues and also cleaning it and still nothing.

Any suggestions?

What does the machine do when you turn it on?

1 Like

It starts as if it were going to start calibrating and then the button turns yellow.

While you’re waiting for support, have you tried the thins outlined at this ilnk?

Yes, I’ve tried everything and still nothing, it’s been down for 2 days now.

1 Like

I’ve tried everything and nothing is working.

All you can do is wait for support, but I doubt they’ll have a solution beyond having to send it in for repairs. Removing/replacing the head with the machine powered on is likely to have fried something.

I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.