Yellow light keeps coming on, tried everything

I’ve run through all the necessary troubleshooting guidelines with tech support in order to fix the problem and nothing has worked. Is it possible that it’s cause by the ribbon cable being bad? It looks to me as thought it has wire showing through due to a possible bend at one time and the ribbon doesn’t track smoothly but instead scraps the top. If this is the problem can I replace the ribbon cable myself?

What did Support say after you went through all the steps?

Some of the ribbons can be replaced, so it depends on which one - but maybe send pictures to Support - and post them here - so someone can double check what you’re seeing before you spend the money to get a new cable.


We thought the problem
Was solved—it ran all day—then, BAM, yellow light and down again.
I didn’t see a place where I could attach a photo when I posted.

Look for this logo:

It moves depending on what you’re using to read the forum. To add a picture to your original post you can click the pencil to go into edit mode first :slight_smile:


One condition that can present that way is overheating due to restricted airflow. Ensure the exhaust fan/grill are free of accumulation.


I’m having the same problem wendysue, I’m about ready to throw this thing out and am seriously regretting my purchase. I have a support ticket in but I’ve tried everything I can find in attempt to fix it myself. Very frustrated and unhappy. For the price, I would not expect to be having these repeated problems. Good luck to you and yours!

I was just offered a refurbished replacement for $1650. Plus tax, but that seems kinda high after only having it for under 2 years, that’s a quarter of the price for new. And how do they know what’s wrong with it, maybe it’s only a few hundred to fix it. But I feel trapped in a way because what choice do I have besides to keep a non working laser. And what if I run into problems again after 90 days?
Good luck to you as well.

Did all that. Cleaned everything.

1 Like

Does it present a yellow light at powerup, or after it starts calibration? If it’s after it starts calibration that would suggest that spot where you see the wire may be throwing that error because it touches something conductive. Just a wild guess, but I would cover that spot on the wire with some tape.

There is a Facebook group called ‘the friendliest GF user group’ or something like that, and Johnathan is the guy there who may have a cable to sell, and advise you on replacing it.
Good Luck!


Wow, thanks for the great and informative information.
It does both actually. Sometimes it starts up and it automatically yellow, other times it does it after calibration, I hit print and then the error message.
I will definitely join the FB group and go that route.
Thanks so much.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.