Zig zag lines

I have noticed that anytime I load a file that has alot of nodes I am getting zigzag lines.
even if the line is a straight line. anything I can do to prevent this?

A picture of the problem would be helpful!


I filled a board with these and it started scoring perfect then went jagged.
So I cut a Gift of good measure and it was fine. Everything worked great went to run another file that had a lot of text outlined on it with a spiral and it did it again.
hope that helps

1 Like

You say the file has a lot of nodes. Are there a lot of nodes in the spiral curves?

Those arcs should be smooth, like the arc on the left in my example: one node at the “top” and one at the “base”. If your curves look like the arc on the right in my example, all those extraneous nodes may be causing your “jagged” stair-stepping.

Screen Shot 2021-01-25 at 11.06.14 AM


It also looks like this is an engrave yes?

If so, which engrave settings did you use? It looks to me similar to what I’ve seen with “Draft” engraves.

For something like this, I’d use “SD graphic” and I’d expect a smoother edge.

SD graphic basically uses more lines-per inch (LPI), effectively giving you a higher resolution.

You can hand tune those settings as well, if necessary.

its smooth lines. it started smooth then went jagged about half way through

it was a score

if you feel like uploading the file, i’m willing to take a peek and see if I notice anything weird and if I can replicate your issue.

1 Like

the issue is when there are too many nodes. It happened again on another file I was working last night that had over 300 words plus a pretty large graphic image. I was just wondering if there is a way to mitigate that issue?

As a matter of routine, I tend to use “Simplify paths” in Illustrator. Inkscape has something similar.

I usually use it to reduce nodes in a nearly lossless way (i.e., it doesn’t actually affect the shape, or it does very, very slightly).

e.g., I’ve been doing topological maps, and I had one I had first designed with 40k or so nodes. Using default “Simplify paths” settings in Illustrator brought it down to 12k, with nearly no visual change. And GFUI is much happier with the 12k nodes.


The request for your art is because it’s not a standard issue - likely there is something in the way you’re creating it that’s causing it. If you don’t want to post it to the public forum you can send it to support@glowforge.com and they can look at it on the back end, but they will give a less detailed response than another user - since their focus is the machine, not the art.

1 Like

that is exactly why I would be interested in looking at the file. The design looks too simple to me to have enough nodes to start causing issues.

For reference, I regularly have to deal with gorgeous-looking vector art that was designed specifically for print, like this portion of an image (in outline mode) that has ~911,000 nodes :pleading_face:


You have jbv, a professional graphic artist offering to diagnose your file, I would graciously take him up on it! :wink: you can zip it, drag and drop here, or message him privately if you wish.
A good example of why this community is the best accessory for your laser! :sunglasses:


Hello @toddstruemail, thank you for reaching out with your question. It looks as though the community is offering some great advice.

The best way to solve this depends on your design. As @jestelle mentioned, you may be able to simplify the design with your design software. Inkscape and Adobe Illustrator both have options to simplify strokes. Another option might be to convert the portion of your design which is to be engraved to a bitmap by rasterizing it. Here are two support pages on these topics which might be helpful:

Rasterize Objects

Simplify Strokes

If you converted your image from another source, you might be able to perform the conversion again. In any case, your design will likely print successfully if it has fewer nodes.

Please give it a try and let us know how it goes. Also, as mentioned earlier, if you’d like to share your design file we’ll be happy to take a look. You can either post it here or email it to us at support@glowforge.com.

1 Like

Everyone keeps referring to the file. it isn’t the file.
Here is the Gift of Good Measure

if you notice there is a zig zag in it as well.
It is because of nodes either…soooo looks like its a machine issue!
I have checked all wheels, Checked Belts, and even looked and cleaned the rails.
can anyone think of something else I have contacted support but lets face it they dont respond the fastest.

Thank you for offering to reach out on the file. it isn’t the file unless the Gift of Good Measure is an issue too lol.
love the artwork though!

the only other thing I can think of off the top of my head is to check whether the belt pulleys are fully seated. I have had an issue where the back right pulley slowly works its way off the bearing and away from the side of the case. I replaced the pulley the first time, but the last few times I have noticed it I have just pressed it firmly back into place with my thumb (takes a few months to work itself back out).
I just pressed it back into place again today, forgot to take a before picture. here is the after picture (pointing to the pulley with a wood scrap)

It looks ok to me
I went ahead and check all the others as well, none seem lose and the belt appears seated on all of them.

Thank you for running the Gift of Good Measure print and clarifying the issue. I see that you’ve also emailed us about this issue and we’ve been working with you there as well. To avoid duplicate communication, I’m going to close this thread and we will continue working with you over email.

1 Like