Introducing Snapmark (September 2018)

Have you had your GF replaced, If you have it was probably added to your old GF.

Nope, same one I started with.

Have you refreshed the browser? (And which browser are you using?)

Very happy with Snapmarks! It was easy!

I received the email earlier this week

7 Likes

Snapmark workflow ? (really more of an inkscape workflow)
I got the pencil Ssnapmark to work with no issues.
My question is: I want to cut out paper house designs using Snapmark. How might this be done?
I start with a paper house design that is embedded in a .pdf. In this case it’s coming in as a graphic. I have had one come in as a vector before and had no issues.
I import the correct page of the pdf (graphic).
I add lines to cut and score.
I then add snapmarks from the pencil template
In order for this to work, I need to get this document printed to paper because the house has colors I want to preserve.
Since the pdf came in as 8.5 by 11 I need to change it to 20 x 12 and save as svg right?
I’m having a problem getting my inkscape to print the design on 1 piece of paper and also getting the snapmarks to be recognized.
Thoughts?
Would it be possible to save the svg as a .pdf, then print it?
If you import a .pdf into glowforge, what page dimension size does it need to have to preserve dimensions? or is it not possible?
I did have 1 house that came in as a vector. Unfortunately these other houses do not.
My goal is to cut out page 5 of this pdf document. This is from the website http://www.versailles3d.com.
Thanks for your input.

Howard

Chateau6.pdf (5.4 MB)

image

1 Like

I have that process written up here:

It’s the Working with Print and Cut Files section. :slightly_smiling_face:

1 Like

thanks a bunch. I’ve blown about 5 hours in the past 2 days on this.
Our son let us know his project is due Friday.
We’re attempting to remake the Chicago worlds fair. It was built to look like Versailles.

Howard

1 Like

Should be doable if you already have the vector cut lines and score lines created. (That’s the hard part.) :slightly_smiling_face:

Yeah. Cleared the cache. I’m using Chrome 70.

Huh! Don’t know what else to try. Presumably you have turned off the machine since then and let it install any updates. Maybe it got assigned incorrectly. The team might have to look into it for you. :frowning:

This video helped me, but I also ran into trouble with printing from Inkscape. Once I got a correct printout with Snapmarks, the cuts were accurate. Inkscape has its limitations.

Okay @bonny, I have to report a dark screen situation. (This time I kept my head long enough to pull some screen shots.) :smile:

This happened at about 9:35 pm CST, Sassy1.

Prior to this happening, the app had hung while uploading a file. It contained multiple rasters for engraves, overlaid, that had been rotated through 90° and resaved as a new SVG and loaded fresh. After it hung up the first time, I cancelled the print, then turned off the machine to get it unstuck. Restarted, let it recalibrate, and this is what happened after I reloaded a copy of the file that had the raster images removed. (To speed up the load, they weren’t really needed at that point.)

The revised file loaded without issue once the rasters were removed, but I got dark-screened when I hit the Snapmarks button:

Dark1

It snapped just fine, everything lined up:

After I printed the Snapmarks to see if they aligned, the screen remained dark until the image refreshed after the print.

So it’s a glitch that doesn’t impact anything other than look startling, and it might be because I had to kill the earlier print and restart the machine while it was still trying to deal with the upload.

Anyway, just reporting it. :slightly_smiling_face:

1 Like

Just used snapmark for a large job with 300ish ornaments front and back. HOLY SMOKES it made it so much easier. PLEASE keep this feature. Once I figured out that the snapmarks work better in the center of the GF (because of the fisheye lens) I got it to work every single time. And was able to replicate a front and back for all ornaments in record time. I LOVE SNAPMARK.

7 Likes

So, 2 weeks ago I got an order for 25 custom designed wooden spoons. They wanted a “Friendsgiving” design on the back of the spoon head. No problem, right? Only, no snapmarks yet :confused: so I made myself a jig using the skills I had and it worked great. I was able to pop in 3 spoons and engrave them and then pop in 3 more, etc. But, I was only going to be able to use the jig once if I had to move it :open_mouth: what to do? I procrastinated removing the jig from my machine for just long enough to receive my snapmark email!!! I downloaded the snapmark file and added them to my jig SVG and re-uploaded the whole thing. I did a few more spoons before I got up the nerve to remove the jig and then I crossed my fingers, toes, eyes etc. and prayed it would work. IT DID!!! I love snapmarks!! here are my spoons and jig. I did a Friendsgiving and a Friends Christmas design. :smile:

19 Likes

Oye… still not a sign of a snapmark around here - though I think the alignment of the machine / software has improved? or is it just that i’m subconsciously lining things up better? Would love to have them SNAPmarks please?

1 Like

My challenge is that I had to cut down a long board that only fit into my work room on a diagonal, and couldn’t run ‘square’ through the Glowforge. Normally I’d use a saw, but hey, I have a laser, so … I just used Snapmarks to do a square cut across a sheet of wood that I had to have ‘angled’ in my Pro. I printed the attached SVG on paper, taped it to the wood so that was square and crossed the wood, then aligned the SVG via Snapmarks to the wood lying on a diagonal through the Pro passthrough slots (due to the wood being so long it wouldn’t fit in the room straight). Then I ‘ignored’ the Snapmarks and ‘cut’ the line, and the line cut perfectly through the printout and the board, exactly where I wanted it. Yay, Snapmark!

CutLineSnapmarks

6 Likes

I am kinda feeling like when I was waiting for Puff to arrive and everyone was showing off what they had done and discussing all the nuances and I had no actual Glowforge to try them on,

3 Likes

I have the exact same issue. I got my e-mail on November 6, but so far no magnet icon? I have tried different browsers and no luck :frowning: Could really use the feature for a project coming up too …

Have you had another machine? We have seen where they enable it on a machine that was sent back for warranty reasons.

Nope. This is the same machine I was originally delivered. Otherwise it works great though…