Adobe Illustrator CC - Why is this cutting twice?

That’s curious. What tool did you use to create the circle? The circle shape from the Shape Drawing tools?

@Jules,

Yes, I used the “Ellipse Tool (L)” on Adobe Illustrator CC (Windows 10).

-Novak

I have a similar problem when I create a dashed line in Illustrator. Now I am aware that the GF software does not recognise a dashed stroke line and therefor I expand my strokes(dashes). Then offset the path to find the center line and then give that line some weight with a stroke again. This way every dash is a vector stroke.

Now when I cut this the GF will go back and forth over every dash in the shape. Any idea why?

Based on feedback given here I did a Google search to find out how to align a stroke to the center and apparently it’s in the “Stroke” panel then “Show Options” then “Align Stroke”.

I have not tested a cut yet but at least it looks promising?

-Novak

Capture

1 Like

That one I can explain…when you use offset on a closed shape to find a centerline, you are actually creating a rectangle inside - a very skinny one. So the beam will go around in a rectangle shape.

@novak - That shouldn’t be happening. But I did see it happen myself recently on something else I was testing. With those steps, you should be creating a single stroke ellipse that will cut once.

The default for Illustrator is a center stroke, so if you didn’t change anything, it wouldn’t have had an impact on the circle you drew.

@Jules,

So I went and loaded up an old file of a simple oval key tag and noticed it was a center stroke. That certainly seems to back up what you said.

I then closed out of Illustrator completely, loaded it back up, selected the ellipse tool and drew a simple circle.

It seems my default is an inside stroke now?

All I want to do here is have my circle be a different color (so that GFUI makes it a different “job”) and cut this darn thing out. :slight_smile:

-Novak

AHA! Eureka! Biddly-boop!

Do you see that little carat in front of the word Stroke? Try clicking that and see if you can set it to Center. That might be the bogie.

yup. literally copy, switch to the browser, go to the GFUI home page (the one w/all the designs and the upload button), hit paste. voila.

https://sjc3.discourse-cdn.com/business5/uploads/glowforge/optimized/3X/9/9/999fc001f6cacf1d257fe49cac5da37fad50d08e_1_326x500.PNG

yes, that’s where you find the centerline. under align stroke, you want it on the left (center), vs the middle (inside) or right (outside) stroke. your file was inside. it is center by default normally.

but, as you noted in your second pic just posted, somehow you’ve managed to change the default to inside. did you draw that in a blank document or inside of a document you already had?

if you have nothing selected in a document and change a setting in the stroke palette, it will now be the default setting for anything new you draw in that document.

there are also settings you can make that are universal by changing them with no documents open, but stroke is not something you can set with no document open, so I don’t know how you could do that universally.

@Jules,

That’s the funny thing… I see no way to change anything from the “Appearance” panel. One has to go to the “Stroke” panel to change the “Align Stroke:” to center.

They definitely don’t make it easy but I do think we’re on to something here (I have not done a test cut) because my other designs (which work properly) appear to be center aligned.

-Novak

@shop,

First, thank you SO MUCH for explaining the cut/paste. Wow… that saves me a TON of time as I no longer need to save everything as an .SVG and upload it. That is SO much nicer! (Not to mention sane!)

I think I’m going to simply reset everything in Illustrator as I have no idea what happened.

I’m sure it’s my fault and I’m sure it’s something stupid such as when one thinks they’re in a different window and they start typing… which is just all sorts of “hotkeys” inside Illustrator.
:slight_smile:

A total Illustrator reset is probably my best friend right now.

-Novak

you should be able to do that by starting illustrator with ctrl/alt/shift held down. that will delete your presets and start fresh.

https://helpx.adobe.com/ee/illustrator/using/setting-preferences.html

1 Like

I don’t have the latest version of AI, so i’m a bit limited. But like @shop mentioned, once you set the tool (in this case the ellipse tool) to draw with an inside stroke, it will assume you want to keep using an inside stroke for the next one that you draw.

So what you need to do now is…draw a new circle, select it, then click on the stroke setting and change it to center oriented.

From that point on, your circles will be drawn with the correct default center stroke orientation, and you can merge them into your shape. (Somehow that one just got set to inside the circle orientation somewhere along the line.)

1 Like

actually, you can just make sure nothing is selected and then anything you change at that point will be the default setting for any object you create. same for fill, stroke colors, stroke style, font, etc.

1 Like

Illustrator - How do I reset my preferences?

There are two levels of reseting your preferences, the first and more commonly known is to:

Windows users: Press and hold Alt+Control+Shift as you start Illustrator
Mac OS users: Option+Command+Shift as you start Illustrator


After doing this it appears things are back to normal. Drawing a simple circle now shows a center stroke!

Once again, I haven’t cut anything yet… but (after comparing known working files from previous projects) I suspect this was the culprit all along.

Thank you everyone!

-Novak
Capture

2 Likes