Cancel crashes network and laser keeps running

I use Develo ethernet over power plugs - robust, fast used them for years without issue.
Connection to GF fine, worked exactly as it should.

However, last night I had to cancel a job - it trashed the settings on the Develo switch and lost all connection to the GF cloud.
Reset everything, ran a couple more jobs fine, then hit cancel on another job, same thing all over again.

Then today, a much worse issue, running job, hit cancel, the job DID NOT CANCEL, the Develo switch again has all settings reset, but this time the laser just keeps on running.

Incidentally, the app continues to report the GF as “cancelling” - logout, browser cache reset, etc none of these clear it.

This is similar to other reported router issues and the like, but definitely not the same and definitely a concern when the laser does not cancel.

I think the preferred method of canceling a job is opening the GlowForge lid. I have not been able to cancel from in the user interface.


You should definitely start a thread to report this along with your browser details.

1 Like

Remember that there are two connections involved here. One is the link between your browser and the GF cloud, the other is the link between the cloud and the GF. Ironically, I think what you experienced is generally supposed to be a feature: once the movement/zapping file for a job has been downloaded to the GF and the blinky button pushed, the rest of the process doesn’t need working wifi to continue. (Which is good in situations where connections are slow or inconsistent, because realtime cloud control of the machine would never work.)

But yeah, no cancel would be scary.

How would data passing from the GF cloud to your GF (telling it to cancel) cause the Develo switch to lose its settings? It must have a bug if that is the case.

1 Like

Since this report, I have just tried it specifically and yes, it it quite consistent.

Hitting the CANCEL button resets the WiFi settings on the Devolo plug.

Very weird - I’ve never seen a piece of network kit respond to what’s going on over the network, but it is exactly when the cancel is pressed that it all goes wrong…

Just a bit of extra info, lifting the lid causes the same problem

Does it kill your print though?

Lifting the lid killed the print, the cancel button didnt

Is the Devolo plug on the same mains circuit as the GF? Perhaps it is noise on the power line that upsets it rather than the data going through it.

It may be, though firing up other kit has never bothered it - and it is curious that even a software cancel should trigger it… FWIW I had to cancel two jobs today without issue…

Unfortunately, the interaction with your network gear is outside of our team’s scope. I’ve moved it to the Beyond the Manual so the discussion can continue there.

Regarding aborting a print, in the case of an emergency, pull the plug on the back of the unit to cancel.