Copying from one inkscape file to another

How do you copy from one inkscape file to another while keeping the vector qualities?

I have an SVG, and when I go to copy the design into a new file (using the copy and paste on the inkscape menu bar on a mac), I get a bitmap version of the vector in the new file. Is there some extra special version of copy I should use? Duplicate only seems to duplicate within the file.

Does the original version of the file contain a bitmap as well as the vector version?

What I do is just open a new file, tab over to the original and do a CTRL+A and a CTRL+C, then hop back to the new empty file and CTRL+V to paste it in.

The original contains vectors only.

I have the same problem if I create a simple circle in one file, copy that circle, and paste it into another file.

Huh! You might need to convert any shapes created using the Rectangle or Ellipse tools to Paths. (Also text.) I just copied over a couple of tests, and they came over as the originals did, but those still need to be converted to vector paths. (Path > Object to Path).

That’s the only thing I can think of unless there is some sort of setting somewhere in the Preferences that automatically converts it.

This is weird, all I can think is that it is something about the original file. I copy/paste vectors constantly.

1 Like

Forget about the original file. I get this to happen on 2 freshly created files. I can’t copy vectors between them. Is there some setting I may have changed?

I’m sorry, I’m at a loss, I hope someone shows up that can help. I looked through the document properties (PC) and nothing. I would think that the Mac clipboard is at least as smart as the PC’s?

o2p didn’t change the behavior


Thanks, @evansd2. First for letting me know that I am not alone. Second, following some of the links lead to a workaround: a prefs change in Xcode. Now it works normally. The apparent downside is that I won’t be able to copy outside of Inkscape (or any other X11 program) to a mac program.

Solved in under an hour – many thanks!

1 Like

Assuming you are on a Mac, you have to disable (uncheck) the “Enable Syncing” option in the XQuartz preferences.

Looks like you got the answer as I was typing it.

1 Like

I run Inkscape via Xquartz, and I just file/ import another svg file in the current one; ungroup any elements and you’re all set.


Yep, just import the file as you would any other file format. Easy breezy!

1 Like