Current users of Cricut, or similar machines

Although the Gazelle came with SureCutsaLot 3, there was no serial number sticker present so I couldn’t register it.
Not prepared to shell out more than I paid for the machine, so when I found that inkcut would work in Linux, I switched to running that from my desktop, and determined that would be the way for me to go.
When I cut the first ‘garnets’, there will be much rejoicing in the land !



I wasn’t aware of Inkcut. Nice to know there is a FOSS option now.


Having some issues with it, but I’m hoping to get there !


I have been a cricut user for a while (its what started me down the path to getting a GF). I find it is a good companion to a GF. What is nice about them is that they are hard to break. So I would look on facebook marketplace or something like that for a cheap used one. Just make sure and watch it cut before you pay for it. If it cuts fine, there is likely no issues with it.

As for things like the cricut heat press, I have had those go out on me. I ended up using a cricut mini more often then the heat press and so I would recommend that if you are looking to do HTV.


The cutter works fine, it’s the software that I am needing to become more familiar with.
As I paid only $40 for the Gazelle(mind you the post and tax doubled that !), I’m content to find the cheapest way to get it running. My only current need is to be able to cut the ‘garnets’ (see my other threads) for the Anglo-Saxon fan design, and I’m getting there.
Re heat press - I already am equipped with a 15" x 15" press.
With the two cnc machines I’m also building, the design/workroom is getting a bit crowded, so I’ve promised Wendy that I’m only likely to be working on the internals of the machines from now on !


I know the feeling! I joined my local maker space and offloaded my kiln and random stuff there. Being part of a maker space has really provided some extra room at the house :slight_smile:


Perhaps you’ve given me a clue.
There seems to be no local maker space, so do I need to start one ?
Goodness knows what Wendy would say to that idea !
Perhaps a casual visit to the local technical college might be fruitful.


Or event the local library :slight_smile:


While these attachments might show an effect only found in my inkcut/Gazelle set up, I wonder if anyone else might give me a clue to what might be going on !
In order to show the problem, I’ve used a pen rather than a cutter blade.
Firstly, the ‘test’ cuts work perfectly.
If I then send a simple shape to the Gazelle via inkcut, the output shows additional paths that would be cut. It’s consistent in making the same paths for a given shape.
However, if I rotate the image in inkcut, using the ‘Graphic Rotation’ menu, the paths change, depending on the degree of rotation, or even disappear !

Any clues ?

Screenshot from 2023-07-21 18-04-00

Wow, that’s wonky.

I haven’t seen that with my Gazelle but, I am not using Inkcut. I do all my design work in Inkscape and, just use MTC (or, on rare occasion, the Bosskut software) to send it to the machine.

1 Like

I’ve now gone back to the laptop with XP running, and using the installed Sure Cuts a Lot software in Demo mode, I get the shapes, but with the cross cuts added.
I’ve tried the now installed MTK, added the Gazelle plugin to the plugin folder, which adds GazelleInstall, but MTK can’t find the Gazelle, even though it shows in the drop down list.
I’m assuming that, though the Bosskut program can see it ( and I don’t remember manually installing it !) I’ve done something wrong in trying to install it for MTK.
Goodness knows what to do now.
I know its possible get round the diagonal cut at the end, so I really need to pursue this.

1 Like

I created a similar shape in Inkscape, imported it to MTC (running on a Windows 10 VM) and, output it, both as-is and, rotated a couple different ways:

Here are my notes on installing MTC:

Install the CutOk Driver
Install MTC
Install MTC Gazelle thing
In MTC: Help > Advanced > Install CutOk driver

I tried to install Inkcut on the studio Macbook Pro. Python won’t install because “Xcode is outdated.” Xcode is the latest version that will run on that OS (Catalina). So, there’s a whole hairball of updates to make that work.

I tried to install Inkcut on the Windows 10 VM but, it failed because it ran out of space. I probably have to rebuild the VM to make that work.

This is all in keeping with the fine tradition of python invariably being a PITA to install (except on microcontrollers, where I have never had an issue).

I will try to resolve one of those things so I can try Inkcut but, I can’t make any promises about when.

I have had stuff updating and reconfiguring all day. I will spare you the details but, I got both MTC and Inkcut working with my Gazelle in the Windows 10 VM.

Here is what I did:

  • Install CutOK driver: extract files, open folder, right-click on the setup file and choose Install
  • Install MTC
  • Install the MTC Gazelle component (see DM for link)
  • In MTC, choose the Gazelle

Inkcut uses the same CutOK driver. In Inkcut for the device setup, choose device > setup > connection > printer, then select the CutOK printer. Let me know if you need more detail on the setup for that.

Here is my test SVG as imported and, rotated in Inkcut.

1 Like

So I’ve decided to dip my toe in the water of virtual machines !
Years ago, it seemed to be a pretty complicated process, but now it’s just two commands in Terminal, and there it is !
Onwards and upwards and look for a copy of Win 10 !
Thinks - I’m sure I’ve got an old hdd with that on :thinking:


Managed to get a Gnome box set up, after problems with Oracle Virtualbox, and now have win 10 running in it.
About 20 years since I’ve used windows, so relearning curve ahead !


Got lots of downloads, but fallen at the first fence of trying to get them into the VM !

Can I connect my VM to the internet, and download them directly ?
When I try to download, Windows says it can’t download the driver securely, so cancels it, without giving me the option to accept the risk.

Getting them from the host machine into the vm seems to involve lots of extra installations, and confusing isn’t the word for it !

tl;dr: Try downloading the driver in the VM by adding an s after the http part of the URL:

I don’t really use VirtualBox much. My VMs are running in VMWare (Fusion on the Mac but, have also used it on Linux). I can just drag-and-drop files from the host machine’s file explorer to the VM’s. My understanding is that you can also do that in VirtualBox, though you might have to enable bidirectional drag-and-drop in the Devices settings. Another possibility would be to put the files you need on a USB flash drive, then connect the USB device to the VM.

My Windows VM is a normal full Windows installation. It has the Edge browser installed with the OS, which can be used to download a better browser (e.g., Firefox). You should be able to download software and drivers with Edge or Firefox.

The CutOK driver is offered via an HTTP link on the download page. Browsers have gotten twitchy about doing anything over HTTP, preferring the encrypted HTTPS and complaining without it. The CutOK site does have an SSL cert installed and, you can just add the S by hand to get a link that shouldn’t make a browser barf (i.e., ). You can also tell the browser to just go ahead and download it anyway, despite the “risk.” For Edge: How to tell Microsoft Edge to let you download a file it's blocking - CNET


Thanks man. I think you’ve just given me a master key that will open the door for me. Just add an ‘s’ !!

1 Like

I’ve turned off the SmartScreen in Edge, in order to download the driver, but that hasn’t had the desired effect.

Now discovered that the Flatpak version of Gnome Boxes that I’m using doesn’t support usb redirection, so even that method of getting the cutok driver in wont work !

Plodding on.

Are you going to be able to connect the Gazelle to the VM?