Design Problem - Probably an easy


I attached the file, in illustrator I embed the graphic, was a PNG file. used the draw inside feature to create a clipping mask to easily have the design only where I want it.

However when I upload the file it removed masks and converts to paths and the full image appears.

How can I not use clipping masks but have the same effect of putting an image or pattern just on the piece I want to cut out


I can’t help you with Illustrator (I use Inkscape), but I’ve moved this to the appropriate forum - P&S is for technical support issues.

okay thanks!

In Affinity Designer, once I get the image clipped the way I want it, I rasterize it. That creates a new bitmap without clipping paths. No idea if AI has the same sort of thing, but I thought it was worth a try!


This is what I see when opening your file:

Strange… not sure why the graphic isn’t showing up. Im trying something now that might work, ill upload another file in a minute if it doesn’t work

1 Like

It likely was linked inside the svg instead of being embedded. (2.8 MB)

try this one

I believe I found a fix. I cropped the overall mask to the size of the piece, engraves a little bit in the wasted space between pieces but if anyone know how to make this clean and simpler that would be great for future reference

The Glowforge interface does not handle clipping paths. You can rasterize the image with the clipping path to create a new raster image, but for something like that, you can also just let it engrave the whole thing…it’s not going to add much time to it and the overlap is in the waste area.


Ok I see. You can’t use clipping masks as far as i know. But you could leave off the clipping mask and just let it engrave into the waste since your actual cuts will be clean through the overlapping engrave.

1 Like

Not sure if it is the same in illustrator but ive dont the same thing in inkscape, and afterwards once i get the image the size/ shape i want i then export it as a png and then re import it to the design

1 Like

yes the latest file I uploaded as after cropping, before that everything was just jumbled. but a little overlap won’t be an issue now. thanks=]

The forum software automatically strips any images out of svg files. If you want to upload an svg with an embedded image its best to zip it first and upload the zip file.


Thanks. Good to know.

1 Like

I have a weird workaround that I discovered in design school. I’ll attach screen shots to explain:

First you will want to place your pattern image as a JPEG in your AI file. Create a filled version of your box shape:

Move your box shape over your pattern:

Select your box shape and bring the opacity down to zero:

Select both box and pattern shape, go to Object-Flatten Transparency-(Choose default settings or the ones here):

Ungroup your objects, and voila!


Ooo that’s a new one!

1 Like

Thank you!!! much appreciated =]

1 Like

Bookmarked! What a great tip!

1 Like

Out of likes, but nice share of information!

1 Like