File Conversion - Pattern in GF

I purchase a file from Etsy that I have since converted to svg. The file is a pattern for a wallet that gets sewn by hand, therefore there are chisel holes already in place for the stitches.

When I import the svg into the GF app it tells me “the dashed lines are converted into solid lines.” How can I stop this from happening…

There is a dashed line to path conversion in Inkscape I believe. (Check the plugins or extensions area.)

So I would have to take it back into Inkscape? I cleaned it up and converted it in Cameo I am not having a grand time with Inkscape at all…

I’m not familiar with Cameo - it might have the option to convert a dashed line to a path. But you will have to convert it in something other than the Glowforge interface. It can be done in Illustrator or Inkscape, and probably Coreldraw or Affinity Designer. Any of the major vector design programs should be able to handle it.

A dashed line only “looks” dashed, the underlying path is a solid cut line. There are ways to break them up, but they vary by program. What you are wanting is a bunch of short broken up paths, so the laser follows it and doesn’t cut a solid line. The laser sees the underlying path.

There are a bunch of tutorials and discussions on dashed lines in the Matrix (for the various programs) check out line 136 on this spreadsheet.

1 Like

The pattern already had the chiseled holes I didn’t need to do anything I imported the SVG into glowforge and gf converted it and I didn’t want that

The GF app isn’t converting anything. The original used a single dashed line (path) for the stitch holes. You need to convert it in a way that the dashes are broken into individual paths. Jules told you how.

1 Like

More explanation…Open the SVG file in Inkscape and click on View > Display Mode> Outline.

Here’s an example…this looks like a dashed line in Inkscape:

But when you go to Outline display mode, you’ll see the actual path is solid.

The Glowforge looks at paths, not the appearance of the object. So we have to make the path match the appearance and actually break up the line. If you want to do that in Inkscape, just follow the tutorial at that first link I gave you for Inkscape. (Or you can use Illustrator or Corel…looks like both have tutorials listed.)


So I want to be sure I am not crazy please view this message and tell me why it says that?


Ok so its not a dashed line… they are actual chisel lines for sewing… if I make dashed lines it won’t work… But thanks I will just have it cut and I chisel my own holes…

If you want to Zip the SVG file and load the zipped file up here I can take a look at it and see what’s going on with the dashes (or chisels). But without looking at the actual SVG file it’s hard to give you a definitive answer.

Because it’s letting you know, the dashed style will be replaced with the underlying path.

I was mistaken in saying it’s not converting, as clearly it says it is, but it’s doing it for the reasons already stated - a dashed line is a visual representation only, the path is solid. Use the “convert dashed line to path” option to break it apart.

But it can’t be in that sense… it has to be small chisels and if I break it apart it would be uneven…

Anyway I figured out the problem. In the pattern, the person, who created it, made the chisel lines/holes. However, on the pattern he also made short lines to show the direction of the stitching. When I converted the files it filled in the spaces between the holes… and some how when imported it assumed it were dashed lines. When I removed that stitching behind the holes and re-saved it it clearly has the chisel / holes…

I got it Jules I replied below thanks though I got it figured out…

1 Like

Glad to hear it! :smile:

1 Like

Me too it was driving me bonkers! Sheesh! Now I know thanks for putting up with my shenanigans LOL

Actually can’t remember one with sewing lines in it before, so it probably would have taken some time to figure out anyway. :slightly_smiling_face:

1 Like

This topic was automatically closed 32 days after the last reply. New replies are no longer allowed.