Focus issue with lens fixed

Like many of you I had a hard time focusing the lens, and got an extra wide kerf that wouldn’t cut through the material. For me, none of the standard advice worked. My solution is very unorthodox and I wouldn’t recommend it unless you’ve tried everything else and are desperate like I was.

Assuming your lens is not upside-down, if you have accidentally pushed/slid the motorized holder for your lens either up or down too many times in one direction, then you can (when the machine is off) take the lens out, and push it back in the opposite direction you have been accidentally pushing it. Then fire up the GF. If you do this several times, it would seem to put the readable height of the lens back into a window that the software recognizes. You’ll know if it has worked because the “set-focus” function in online software will start working again without giving you - the material is the wrong size message. Make sure to read updates below

I got the idea because I was talking to the support staff, who noticed that the height numbers on my lens changed once when the machine was off (they were looking at the logs). They didn’t know I moved the lens-holder manually to see if maybe that would fix the issue. Then I realized that I had been moving it up too much in general. The staff told me that I had to send in my machine so that they could manually calibrate the lens position with their software, which isn’t available as an over-the-air service.

Anyway, if someone sees a flaw in this logic, please let me know. I will delete this post if it can cause other issues for people. Also, please do not try this if you have never moved the lens manually. As for me, my machine is up and running perfectly again.

Update: Support is now saying that, even though I might have gotten my machine to work, at some point it will probably stop working again because the calibration needed is more sophisticated than just moving the lens. Also, there is a possibility that the lens movement mechanism is very fragile. It doesn’t appear to be so, but there could be sensitive switches attached, or other sensitive parts. To be clear, support has made no mention of this, just the commentors below. I will leave this post up in case it keeps yielding useful insights into how the GF works. I no longer recommend anyone trying this until certain answers are given about calibration and lens movement sensitivities.

Update 2: It would seem as if moving the lens should have no affect on lens calibration for nearly everyone. The lens returns to a base-state using magnets each time the GF starts. If my machine is not doing that, hence the need for manual correction, then there is clearly some other problem that is messing with its regular return to position 0. Also, after looking at all the parts and descriptions, it doesn’t appear as if the lens carrier is very sensitive. With that said, it still makes sense to be careful with it. Most likely my machine will stop working properly again at some point. I’ll have to decide whether to continue manually adjusting it for forever, or to send it in. Good luck to the rest of you with focus issues.


Don’t be poking at your lens!! :smiley:

But that is yet another thing that I would expect we end-users should be able to handle if we only had the proper tools to do so. If they lens height is logged then it should be user-accessible along with proper numbers so that we could adjust it ourselves.

GF has done a wonderful job of making a machine that “even a caveman” can use. But unfortunately, those of us that are a little more tech savvy are sort of left out in the cold with the rest of the unwashed masses when it comes to some repairs that shouldn’t be hidden behind the veil so-to-speak.

Your fix… Perhaps you just got lucky and got it back within spec enough… or perhaps it’s something some of us can do relatively easily with proper care. Lets just file that right alongside “We don’t need to send our machines in to get a head replacement… just send us one…” :slight_smile:

This is very bad advice. The lens movement mechanism is fragile and not meant to be moved manually. This could result in many machines having to be shipped across country for repair.

I’m not sure how it gets moved… do people put the lens back in and push on it with the tool? On the few occasions when I’ve removed my lens, the magnet grabs it right off the tool before I get anywhere near actually pushing on the mechanism.

I also don’t understand how it can go out of range. IIRC it’s moved by a stepper motor and unlike the rest of the Glowforge, has an actual limit switch so that it can zero.


The instructions state -

Gently insert the lens tool
(for removal, my emphasis)
Slide the lens tool up into the printer head until the magnet clicks, then remove the tool.
(for re-install)

I’m sure it can tolerate a little nudge, but forcing it back and forth will certainly damage it.

I hope you read the whole post. I did not recommend people moving it unless they were already desperate and had to send it in anyway. Also, this post is for people who already have a lens out of calibration somehow, mostly likely caused by them accidentally moving it, which I have seen other people in forums have the same issue as me.

But I am very curious about your experience with the mechanism and why you have found that it is especially fragile. It doesn’t seem to be especially fragile. I have fixed many machines by carefully tinkering with them, but if you have evidence that this is a bad idea, then I definitely want to hear it.

1 Like

Ok, so my magnet grabs and moves the mechanism forward. I ignored this until I got a focus issue, and nothing seemed to fix it. Since it moved so easily, and nothing else worked, I tried pushing it back to see if this would fix it. I ended up moving it back several more times in different circumstances, to see if it would have an effect. I have heard of others accidentally moving their lens, and people saying don’t worry about it, and then no problems occurring, and I couldn’t afford to send in my machine, so I carefully started adjusting the lens in the down direction until it started working again.

As far as the limit switch, maybe that is what is broken on my machine. I just did a quick search, and there are people out there with cnc’s that have faulty switches and strange problems, as well as seemingly fragile switches. So it is possible that I could have damaged a switch by moving the mechanism, but the problem occurred before I tried to manually move the mechanism myself. Anyway, thanks for the insight.

There’s a detailed technical description of how the lens homing works on another forum (the magic words are “Interpreting Log Files: 2 - Homing Sequence”). It’s actually a magnetic sensor, not a physical switch, and that clicking we hear at startup is the lens carrier being moved up and down to find the exact point where the magnet triggers the sensor. If it can’t find the home position, I would expect it to fail to start up, but who knows.

I’m not doubting that you got it working again with your procedure, I’m just confused about what happened internally, since it should just drive the carrier up and down to find the sensor, regardless of where it starts.

As mentioned in that post, the number of steps varies between machines, so that’s presumably the calibration needed. It may be possible to knock something out of position so that your original calibration is no longer valid. Again, I have no idea, just wild speculation. I’m not brave enough to disassemble my machine.


Thank you for all of that info. So far, there doesn’t seem to be anything especially fragile about the carrier, and I don’t see why trying my fix would hurt the calibration of a machine that is not already unable to calibrate. The lens should be able to find its 0 position over and over again (based on it’s distance to the magnet sensor) no matter what you do to the position of the lens when the machine is off.

Also, this tells me that something abnormal is probably going on with my machine, because moving the lens should not have affected it at all. If my lens is not calibrating properly, it probably will get off a little more each time I use it, and it will stop working again. Knowing that I fixed it once, I’ll probably be able to just manually correct again, and then the cycle will repeat until I send in the machine.

This topic was automatically closed 32 days after the last reply. New replies are no longer allowed.