From Illustrator to Inkscape to Glowforge: eight cats!

The trace to cut feature worked fine on the cats, other than trying to isolate a cat in the multiple cat file. But there is more than one way to skin a cat, so to speak, and preparing an outline from the original drawing might be beneficial.

I ran into an issue working with @cynd11’s cat file to create an outline for using as a path to cut around the stickers. I have run into the clipping paths error before when importing something from AI to Inkscape to Glowforge. ignored it as it had no consequence, but now I’m trying to figure this out. What was in that file that made it a clipped path? Was it Illustrator’s conversion into a PDF, Inkscape’s end of the conversion, or something in the file itself. this probably deserves its own topic, so if anyone wants they can continue the discussion in a new topic. I’m just tying up loose ends here.

Here is the file opened in Inkscape and rotated landscape. Note as I pushed the group over to the bottom left, the left side of the cats and the bottom row of feet get cut off. Trying to select all only selects all the cats, so it’s not like there is a bounding box around the whole image, but in fact, the size of the image places a clipping path in the document. What the heck is this and how do I get rid of it? A clipping path can be understood as a layer or masque applied to an object that makes the object transparent or visible to it’s surroundings. They are helpful when you want to overlay objects within a design (at least as I understand it. There are lots of other aspects to check out!)

To remove the clipping path that came along for the ride: select all > ungroup > right click on the object > release clip.

Now you have a big black box you can get delete and the image will import without any error messages.

The next issue was dealing with the failure of Inkscape to do a offset. I wanted to offset the cat outline so we had a little more room to play with in cutting the kitties out. You can’t just embiggen the file in Inkscape nor in the Glowforge interface. Doing and offset is the correct procedure.

When I haven’t been able to do an offset, it means that I don’t have a simple stroke to work with. Now that’s strange, because the file looks like a simple stroke at first glance.

It looks like there are simple nodes. And once it is the Glowforge, it does not cut over the line twice, an inner and outer cut.

Actually, if you choose stroke to path, then we do get two paths, an inner path and outer path that is filled:

So you break this apart, remove the inner path and fill. Remove the fill and then you have a simple stroke to perform an offset on.

Now you can see that the kitty has a blue offset outline that follows the contour of the red outline. This blue path then can be chosen as a cut path and the red path can be placed exactly over the outline of the cats to be cut out and you have a little wiggle room. You can offset it more our less, but you have to have a single stroke to deal with.

I hope that helps folks in the future. It certainly helps me. Note the top operation will cut an outline using the offset stroke I mad…The second operation is the rest of the litter I didn’t break apart, and the third operation is the original outline that I can ignore.


Awesome! Great, clear explanation and pics! (Mind if I snag it for the tutorials? You just explained “Coloring Book” effect. )


Whatever you need is fine with me.


Great explanation/solution to a problem that I am sure will stump me and others…


That black box looks like it could be an 8.5" x 11" size page background? Maybe the original PDF artwork was designed in landscape orientation and the Illustrator conversion to PDF may have made a clipping path of the page background if there happened to be artwork on the Illustrator artboard, outside of the page layout? Just a guess.


It is 5.5 x 4.25 size. The transition among programs and formats preserved sizes. Not sure if the clipping path originated with @cynd11 or with the PDF translation. I have been able to open PDFs into Inkscape before but had not clipping path added.


I’m looking at the original .ai file and there is no rectangle there, just eight cats. It is an older version of Illustrator (CS5) and maybe that’s part of the problem.

I saved it to Adobe pdf using the following options:
Adobe PDF Preset: [Illustrator Default]
Compatibility: Acrobat 6 (PDF 1.5)
Standard: None

These are the default settings when saving an Illustrator file as
an Adobe PDF document. Use these settings when you plan on editing
the file again in Illustrator, or when you need to place it in a
layout application such as InDesign, or when the final use of the
file is unknown.

Preserve Illustrator Editing Capabilities: On
Embed Page Thumbnails: On
Optimize for Fast Web View: Off
Create Acrobat Layers from Top-Level Layers: On

Color Bitmap Images:
No Sampling Change
Compression: ZIP
Grayscale Bitmap Images:
No Sampling Change
Compression: ZIP
Monochrome Bitmap Images:
No Sampling Change
Compression: ZIP
Compress Text and Line Art: On

Marks and Bleeds
Trim Marks: Off
Registration Marks: Off
Color Bars: Off
Page Information: Off
Printer Mark Type: Roman
Trim Mark Weight: 0.003 in
Offset from Artboard: 0.083 in
Use Document Bleed: On

Color Conversion: No Conversion
Profile Inclusion Policy: Don’t Include Profiles
Output Intent Profile Name:
Mark as Trapped: Off

Subset embedded fonts below: 100 %

Document Open Password: Off
Permissions Password: Off
Encryption Level: High (128-bit RC4) - Acrobat 5 and later


I see dancing gnomes between the cats :grin:


And then only 7 cats. Mu ha ha ha…


I’m curious as to how Illustrator works these in. It seemed to be a clipping mask applied to the whole group. At least you know where to look for it if it is Illustrator.

Here’s a link to Ponoko addressing the issue.


Hmmmmm. Is it possible that we had something other than a clipping mask? I went back into the Illustrator file, selected all the cats, and checked for a clipping mask: none (greyed out)–the only choice was Make.

So then I opened the pdf file in Illustrator and did the same thing. Same result–no clipping mask.


Weird. Can you make another file, just some squares and circles and send them to me, email, as native AI and also saved as a PDF and see if it pops up again.

Otherwise it is no big deal. At least now I know what to look for and correct it.

I’ll be glad to!

This is soooo cool!

As long as you are exporting new versions for testing, export an SVG and an EPS version as well. I have read that Inkscape does have a couple little issues with certain bits of PDF, although I can’t say if that is the problem here.


Good idea! I did it and sent them along after the other files.

1 Like