GF head stops during print unless design is simplistic. Using AutoCAD -> PDF or SVG

Almost every time I print something my machine stops printing in the middle of what seems to be a well-processed image. I do not believe it is a temperature issue because the problem happens at the same instant each time if I repeat the job. After the unit stops moving, the fan keeps going and the GUI keeps counting as if its working. When the countdown ends, the fan stops normally but the printhead does not move. I cannot use the machine after without powering it off and on, as no operation takes place even after refreshing the page.

I regularly use AutoCAD to create my images, using lines, arcs, polylines. Never splines. I use the kill command to ensure there are no overlaps and the join command to ensure everything is a single path. I export from ACAD as a PDF or ACAD 2000 and convert to SVG. This process works fine when the line path is somewhat simple, but not when the printhead has to make intricate movements.

Please pull the logs from my machine and check, it happened in the last few jobs and I cannot print the current job.

EDIT: I am attaching files. trouble is an ACAD 2000 file format, normal is a regular ACAD format. THE PDF was made in ACAD. The SVG was made in an old illustrator that reads ACAD 2000. I have also created an SVG in Inkscape with the same crappy result.

corbelcut_normal.dwg (155.3 KB)
corbelcut_trouble.dwg (193.5 KB)
corbelcut1 Layer3.pdf (33.5 KB)
corbelcut1 Layer3

Stop at PDF, don’t convert to SVG, and test your results.

1 Like

I have tried both options individually. I have tried as a PDF alone. It does the same thing, in a different position. And that repeats as well if the job is run twice.

When making the PDF I usually using the Adobe PDF “printer” from the layout view. I am now testing it as an export to PDF option…

it FEELS like a corruption of data, can you open your current document in illustrator and autotrace it, save as a .svg and try again?

Do you have the same issue with :glowforge: provided designs? Eg. Gift of Good Measure? That would definitely rule out it being an art issue. If that one is too simple for you to hit the time it dies, there are more complicated ones in the catalog.

1 Like

I have edited my original post to include files…

@deirdrebeth I have successfully printed a lot of things, this just seems to be an often recurring problem. For some reason when I draw things end to end from the beginning, it does not happen. This was too complex to do that way though.

@Deleted I am trying your suggestion

1 Like

I don’t see anything immediately obvious in your .svg - other than the face that it’s not unioned so there are hundreds of short stop/starts.
Are you scoring, or engraving?

When I opened it in Illustrator, I received an error that I had never seen before.

I ran it through Astute Vector First Aid which cleaned up all of the unneeded groups as well as joined all of the line segments.

Give this a shot @jburo and see what happens, maybe?

Removed the SVG. It looks like the warning was correct and it actually didn’t open correctly!

1 Like

I am cutting actually, it is a layered project, this is a mid-layer of 5 sheets.

It is the logo of Staten Island Technical HS in NYC, I am the CAD teacher there.

Ok, so I looked a little closer and you do have a bunch of double nodes, and things that didn’t connect - try this one - I just combined everything. See if that addresses it?

corbelcut1 Layer3_V2

@deirdrebeth Thanks for trying, it cut the gear fine and then started the book and did the same thing.

1 Like

Any ideas for processing this cleaner are a help I think? Though I am not sure why this has to be complicated. I have to leave my lab now until Monday, when I will be resuming trouble shooting but until then I will keep checking the thread. Thank you everyone so much.

Update… I just saved as a DXF direct from ACAD and let the GF GUI read that and it worked… I ran it on a busted piece so its garbage but it got through the print. Now I will tweak it and run it for real Monday. I guess its partially resolved but I am wonder if the DXF will always work?


I’ve used AutoCAD for the past 3 years since owning my GF. Always print to PDF and never had an issue. It weirds out how it might cut sometimes, meaning it’s going along fine and all of a sudden will jump to another part or cut, but then it always comes back. I do the same thing keeping all Plines, so spines, always to ensure points are good, etc. Keeping as clean as a drawing as I can.

Like I said, some weirdness, but never what you’re describing. I’m on vacation at the beach, but when I get home I can look at files too. Been using AutoCAD for 27 years…

Going from AutoCAD to PDF (and almost everything to PDF for that matter besides AI to AI PDF) introduces a lot of strange nesting groups, object breaks, font malfunctions, etc.

Since you have access to a copy of Illustrator I’d suggest exporting a DWG/DXF instead, import that to Illustrator and save either a PDF or SVG (or save on redundant files and just copy/paste from AI to GFUI).
This may not eliminate broken segments/lines, though, those still crop up sometimes. You can double check and rejoin things in AI fairly easily.

Hi @jburo. I’m sorry to see that you’ve been running into some trouble with designs created in AutoCAD being exported and printed with the Glowforge app. I see that you’ve been troubleshooting this with fellow owners, and have appeared to found exporting it as a DXF file was able to get it to print. I reviewed the log files from your Glowforge for any technical issues or errors that could have contributed to any print trouble, but was not able to see any technical related trouble.

I saw @ekla had just posted some great advice regarding exporting the files to Illustrator before uploading them to the Glowforge app. Can you let me know if the suggestions were able to help once you’ve been able to print more on your Glowforge? If you’re continuing to run into any trouble, let me know the date and time of any print attempt that failed, and I can gladly take a look for any further troubleshooting needed. Thank you!

So I have gotten through many more prints. The DXF solution seems to be good, but its unpredictable as it sometimes just says that the drawing is too complex instead of doing the convert. My illustrator version is very old (I am trying to get a new version) so when I do the processing through there sometimes also it fails. I had success taking the DXF from AutoCAD that was not processing direct into illustrator and saving it as a PDF from illustrator instead of AutoCAD, as @ekla suggested.

1 Like

Hi @JBuro Thank you for the update. It sounds like the suggestions were able to help, and you found some added workarounds based on the suggestions from @ekla. I want to keep this thread open to allow you to continue the discussion. I’m going to move this thread to our Everything Else section of the Community since the issue appears to be resolved with the advice and workarounds mentioned. Feel free to create a new thread, or write us at, if you run into any other trouble as you print. That will create a new support ticket and allow us to make sure you’re taken care of. Thank you and happy printing!

Hello everyone and thank you for your help in the past, there seems to be some lingering issues. I did get the newest version of Illustrator and have been successfully processing things from AutoCAD as DXF files and illustrator files.

The machine is still stopping during some operations. More likely it occurs during engrave tasks, and yes it does happen with stuff that I am not processing myself. For example, it has happened when I used the simple circle from the clip art library on GF premium. But sometimes it does go all the way through it. The unreliable nature of this issue is driving me crazy. @Brandon.B there was nothing weird in the log files?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.