Glowforge App showing centerlines that aren't in SVG

I’m working on engraving/scoring a map. I’m using inkscape and I started with a vector file of the roads. I made the stroke wider and then used stroke to path to get the thicker lines as a path. Everything looks correct in Inkscape but when I import to the glowforge app, it’s showing the original center lines. Any idea why this would be?

map

if you upload the svg we might be able to help.

If you don’t want to upload it to the entire forum, feel free to DM it to me, I’ll take a look.

2 Likes

I uploaded it, let me know if you are able to see it. It looks like it’s just a tiny picture in the post

Ah, got it.

FYI You can change that in the tag in the post, there’s a dimension of like 10x10 in there, you can pump it to 1000x1000.

Huh, there is something really janky with that SVG, ther’es a strange ghost copy of the paths off to the side.

I might declare bankruptcy on this file and copy/paste the stuff you want to a new document. Let’s see.

Hmm ok first attempt to just rectangle select and copy paste failed. Trying a more finessed approach.

2 Likes

There we go.

So there were paths there, they were in a strange stroke/fill mode that I don’t fully understand in inkscape. I should google it.

In the meantime, here’s a fixed version:

fixedmaybe

(right click to download)

What I did was isolated one of the offending paths, then did “select same stroke style”. That grabbed all of the invisible paths, which I then turned the stroke paint to gradient, then back to solid (which resets that funky mode, again, I’ll need to google, this has bugged me for a while). This made the strokes visible, so I could be sure I was about to delete the paths I thought I was going to.

Anyway, I tested an upload and it looks right.

Also, this file was a nested group mess.

4 Likes

What are you hoping to do with the wider strokes? Or double paths?

The machine doesn’t understand stroke. It can only follow paths (which strokes contain, usually as a center line). You can cut or score along them, or engrave between them if they create an enclosed object.

It appears you had both the original path, and the ones created by converting the edges of the stroke to paths.

If you’re planning to engrave the whole thing, you would likely be better off converting it to a raster/bitmap.

1 Like

Very strange indeed, i was only able to get them to show up by selecting them doing an ungroup and adjusting the alpha

1 Like

Yeah it was set to transparent.

1 Like

Yar bit of a mess either way

1 Like

The nested grouping was ugly, like 7 or 8 layers deep, for no discernable reason. Assume this is an export from some mapping program, nasty.

@mcarson28, chances are you could also have changed the black strokes on your outlined roads to some other color then the centerlines would have been a different step that you could ignore.

2 Likes

That’s a good idea! Yeah I exported from QGIS as a PDF. What do you mean by adjusting alpha?

So if you look at stroke paint settings it shows you the color as a hex code plus alpha. There’s a slider for red green and blue and alpha. Alpha is essentially transparency. Somehow those lines were set to be black color but 0 alpha, which means fully transparent. You can manually set the alpha value to be full, and they’ll be visible again

I like to use the “select same…” menu item. Select one of the paths you want to modify, then select same… stroke style. Not stroke color, because that will grab the other black strokes, but style, which means exactly match the style of what you have selected.

If done correctly you should then have all the invisible paths selected and you can modify/delete them as you need.

1 Like

Got it, thanks for all of the help!!

This topic was automatically closed 32 days after the last reply. New replies are no longer allowed.