Glowforge will not connect to my new wifi internet

I got new internet service, Starlink. I have been trying for 2 days to get my Glowforge connected to it. I had no problem connecting all of our other devices. But, my Glowforge will not connect. I did follow the setup steps suggested. Still will not connect. Help and suggestions welcome. Thank you!

The Glowforge will only connect to 2.4Ghz. Are you broadcasting at 2.4ghz rather than 5G. Several users in the forum are successfully using Starlink.


I do not know…. How do I find that out?

UPDATED: Use the Starlink app on your mobile device and select “Settings” “WiFi Configurations” “Advanced” to enable a “split” 2.4/5 GHz network. Good luck! :sunglasses:


Thank you! That will not change the speed of our service for everything else?

If your new wifi shows up on the list during the GF WiFi setup process, then it is broadcasting on 2.4GHz, The wifi module used in the machine is incapable of seeing 5GHz WiFi networks.

That is incorrect. It doesn’t matter what network you connect to once you have completed setup. You could connect to the machine from the other side of the planet.


I seriously do not mean to sound ignorant. But, the red highlighted box, I can add for example “Glowforge”? And it will not change my settings for anything else?

@eflyguy: Good to know. I’ve always been careful during initial Glowforge “setup” to put my Web browser and the Glowforge on the exact same WiFi network. I know that after setup, the Glowforge Web “app” is accessible from anywhere.

@robinnreed UPDATED: You MUST change the SSID for the 2.4 GHz network. That will not affect existing devices that use the 5 GHz WiFi network.


@robinnreed: Sorry for the confusion. Believe it or not, I have Spectrum cable modem service, T-Mobile 5G Home Internet and Starlink here. I don’t have my Glowforge on the Starlink because of where its WiFi access point is located. I moved the T-mobile access point into my garage where the Glowforge is located and went through some of the same “pain” as you’re experiencing. :sunglasses:

After running some more tests here…

As you’ve no doubt discovered, it looks like the Starlink 2.4 GHz WiFi network has to have a different SSID than the “default” 5 GHz network…

Again, if you Glowforge setup fails when your Web browser is connected on the original SSID, try the “new” one. Good luck! :sunglasses:

I am giving up for the night… I have kept trying. Thank you so much! So aggravating that it should not be so difficult to get my machine running because I got a better internet. I hope you do not care to continue to help me when I try again tomorrow.

@robinnreed: I’ll be here. I work from home on Wisconsin time from here in California, so I’ll be up early. :sunglasses:


I got it connected. Thank you so much!


Care to say how to fixed it? That would benefit others who might have a similar issue in the future.

1 Like

I did what lightner suggested. Added another Wi-Fi configuration that uses 2.4


I’m happy that you got your to connect. I had a power bump 7 days ago and lost connection. Have not been able to connect since. Been on the phone with internet company, tried separate 2.4…nothing. I can only get it to hook up to my crappy hot spot for a second and then it looses signal too :pensive:

I have been using my GF on Starlink for two years now, it has been wonderful.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.