I have one font not fully working Inkscape

Hi everyone! I have tried everything!! I need help please. I purchased a font and installed to use in inkscape. Only the alphabet and numbers work. No punctuation, special characters, etc. I contacted their support and the designer. They say it is working for them. I uninstalled the font and reinstalled. I uninstalled inkscape and reinstalled the newest version, nothing. It has to be something simple, but I can not find the answer anywhere. I put a topic on inkscape forum and have not had any hits. Anyone know the answer? I have never had this issue, ever. Thanks all!!

What OS? (windows/mac/other?)

Does the font work in any other application on your PC? (like a word processor or something)

What type of font was it? (as in what file type)

1 Like

Sorry, Windows. Font works in my other open office applications. I tried the OTF and the TTF. I can try and post the file?

Probably not a good idea to post a purchased file for everyone else to use.

1 Like

Yeah I was thinking that :face_with_hand_over_mouth:

I suspect you could type out the symbols and punctuation in Word then save as a pdf. Import the pdf file into Inkscape. Not a smooth fix, but a fix nonetheless.

1 Like

That is a great idea, totally could do that! I like to investigate for answers and this one really has me stumped. I feel like it is one simple box that got unchecked and it is laughing at me while I struggle.

This is a fascinating issue that I haven’t seen come up before on the forum.

Are you saying that the punctuation is not appearing in the font edit box within Inkscape as you type it in, but the characters do appear?

Maybe a screenshot of the Inkscape demonstrating this behavior may help us.

1 Like

Yes!! That is why I am losing my mind! There is zero info about this ever happening on any forum that I can see. I had originally installed the free version of this font to see if I liked it. The free version does not give you anything but the alphabet. Then I bought it and still only alphabet. So I started the process of uninstall, reinstall, OTF, TTF, help desk, designer, etc.

I also have done object to path, changed to outline view and still nothing.

Update, evansd2 graciously assisted me, again. I followed his order of operations to install and was able to get numbers now but still no other symbols or punctuation. Evansd2 was however able to open the file and get full access. So it has to be something I am doing or did. I have clean a copy of the latest version of inkscape installed yesterday. Thank you!


Is it possible that windows has a version installed in a cache somewhere that has properly been uninstalled/overwritten?

It’s been a very long time since I broke win XP by finding the installable font limit of 254.

1 Like

This would be a goofy workaround, but if you’ll be using lots of fonts, preferable to installing all them directly: Have you tried a font manager? Fontbase is a great free one.

1 Like

I will have to look into that, never used or heard of it?

Sorry, you are totally over my head on that one! I feel like it does somehow have to do with the fact that I had the free version first though? Just a hunch.