Importing images to print?

ok, I’ve gotten through the initial printing. LOVE IT! Now I’m ready to import text/images. How do I do that? Whenever I click on “Import” it says to drag the file anywhere. I obviously don’t know where “anywhere” is because it won’t work!

1 Like

Have you tried uploading from the home screen or “add artwork” from the GUI?
( Glowforgr user interface.)

from the “Home” screen

from the GUI. (If you add artwork from here, the file won’t be saved on the “Home” screen.)

1 Like

Yes, I choose the file (I’ve saved it as a GIF, JPG, PDF, TIF) none of them work. I get “Drag a file anywhere to upload”

Sorry you’re having trouble. :-/ GIF and TIF won’t work. You can use either SVG, PDF, PNG or JPG. (99% of my files are a combo of SVG and PNG as they seem to be the easiest to deal with.)

It’s so hard to do these things without seeing it, so sorry if this is seems like I’m pointing out the obvious. From the Home>upload>select file>double click. Ignore the “drag anywhere” dialog if it pops up. As the image starts to load you should get the “Hang On…” dialog box and then the “rendering” dialog. To test it out and get use to it, I’d try a few different SVG or PNG file first.

If it forever hangs on the “drag anywhere” box, it might be a wifi issues, but I’m not much help with that. I did just try and upload images to make sure there wasn’t some weird issue effecting us all and they worked fine on my end.

If you haven’t seen this yet, the matrix is the best resourse for getting to know your GF.

1 Like

Which web browser are you using? I’d recommend Chrome, as it tends to work best with Glowforge at this point. You should be able to drag a (PDF/SVG/PNG/JPG) file into any part of the browser window and have it work.

1 Like

I am using Chrome. I cannot retrieve any files. I’d like to bring in a document file and print it to wood, or etch some anodized aluminum, but no matter how I approach it, when it gets to choosing the file, I double click, or select and say “OK”, I get the window “Drag your file anywhere” window and nothing happens.

That is strange. You are starting from the Home tab of the user interface where the pre-loaded designs are located and click on the Upload button from there to choose a local file?

Where do you see the word “import” in the interface?

Or are you just trying to drag a file from a file manager on the the design space?


My two ways are to Upload in design space or Add Artwork in the operations space, but I can also drag a file onto the design space and it loads.